2
$\begingroup$

I would love to see Blender 3.0.1 (and earlier) file thumbnails in Windows 10/11 Explorer, but the fix of running blender -R at the Command window never makes a difference.

I have opened a Command window as an Administrator and successfully changed the directory to the current version of Blender and run the command Blender - R.

I have tried running it multiple times then rebooted my PC and also cleared the thumbnail cache, but I never see thumbnails, only the large blender icon for my files. Yes, I do see a success message each time.

Are there are other tricks or third party tools to display Bender files as thumbnails? (Most of my files are simple models for 3D printing),

$\endgroup$

2 Answers 2

2
$\begingroup$

The link in the answer to this thread led me to this discussion on a Blender bug report. It looks like thumbnails using the blender -R command were broken around 2.90-2.92 and you now have to manually enable them in 2.93+.

Under Preferences->System there's an option to register the currently running version of Blender with Windows for generating thumbnails and opening .blend files through the file explorer.

Blender Preferences Settings

This doesn't seem to happen automatically so you'll have to manually click Make Default the first time you install it on any computer.

Also from the little bit of testing I've done, it seems that the thumbnail depends on whether your scene has a default camera set. Without a camera, the thumbnail is just a screenshot of the entire Blender window at the point you save your file.

Thumbnail without camera

With a camera, the thumbnail takes a square snapshot from your camera, which looks much nicer.

Thumbnail with camera

$\endgroup$
1
  • $\begingroup$ That worked! Thanks! $\endgroup$ Feb 1, 2022 at 20:25
0
$\begingroup$

I found for me it was a corrupt prefs file, which I deleted, then rebuilt and things worked again.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .