I am rendering an animation of a furniture getting assembled using eevee render. Most of it is white but some parts are made of plywood. The problem is that the plywood side texture changes brightness depending on how the object is rotated. I can get it the same value as other sides when I rotate UVs, but once the object rotates it changes again. enter image description here The two objects use the same texture but are rotated differently and have different values

enter image description here and then they change values completely when rotated 90° Things that were dark turn lighter and visa versa.

I could just make them all react the same as where all are dark and get light or the other way around upon rotating but the fact that they change colours at all is not too good.

Is this just an eevee thing and I have something to change in those settings or is the texture mapping way off?

Edit: Just checked and to my surprise it looks like it's a UV map problem since it is the same using cycles too. Face orientation is correct and UV unwrap looks good to me so I really don't know. Maybe I should try projecting from view or just unwrap from scratch as it is an imported OBJ model not blender made.

  • 1
    $\begingroup$ Hi :). Aren't those just light reflections? $\endgroup$ Commented Jan 30, 2022 at 20:17
  • $\begingroup$ hi @JachymMichal! The textures are fairly rough, as natural wood is and it's very evenly lit, both from world texture as well as a large overhead area light and two opposing area lights. Also, changing lights and shadow settings do not change the brightness of the textures as much as rotating objects does. I should do test renders on cycles to see if it's uv and texture issue or just eevee being eevee. $\endgroup$ Commented Jan 30, 2022 at 20:32

1 Answer 1


I just stumpled upon your question, because I had the same problem. I could solve it, so I leave the solution that worked for me here for others, that may find this post.

In my case Auto Smooth was causing this problem. I turned it off, and after this the brightness stayed consistent. You can find it in the Object Data Properties>Normals>AutoSmooth.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .