2
$\begingroup$

when I hit numpad 0 blender focus to object not the camera and when I try to render ı see black screen. You can see this problem on this video. How can I fix this?

https://youtu.be/bgg6i_4iMNA

Edit: I solved the problem. You can see on the my answer or click the link.

https://youtu.be/2yDCiFCg_HU

$\endgroup$

2 Answers 2

6
$\begingroup$

the problem you are facing is that:

  • what you see in the viewport is not what the camera sees (to check what camera views, click on the "camera icon" (check image below) or press numpad 0)
  • the render is based on what the camera sees
  • to match what the camera sees and what you see in the viewport you need to keep the two aligned.

To do it you should:

  • click on the camera icon (or numpad 0)
  • press n to open the right panel
  • in the right panel, under View > View Lock, flag "lock / camera to view" (check the image below)
  • when the "Lock / camera to view" is on, when you move your view in the spaceport, you also move the camera.

enter image description here enter image description here

hope it helps

check also this to simplify all above: enter image description here

$\endgroup$
1
  • $\begingroup$ Thanks man this helped. $\endgroup$
    – Faruk_GENC
    Jan 30 at 16:43
1
$\begingroup$

I realized the problem. The problem is local camera was my object you can see on the image. enter image description here

now its fix :D

enter image description here

$\endgroup$
1
  • 1
    $\begingroup$ good, this is something useful for other people too :) $\endgroup$
    – Sanbaldo
    Feb 1 at 11:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.