1
$\begingroup$

I was experimenting with Blender to create a custom video transition with a transparency layer using the general 3D design tools. I was able to output a video with a transparency layer which I tested on a website to confirm that the video shows transparency (rotato.app) which showed that the video had and transparent background.

EDIT: I've discovered that the issue is with the previewer in VSE. This shows the transparent layer as black but when I render the video with my transition then everything renders with the transition sequence being transparent where it shows black. Does anyone know why the previewer isn't showing alpha layers properly? I have selected 'Colors and Alpha' as display channels on preview.

When adding this back into Blender in the VSE the transparent parts of the video are showing as black. I have tried using 'Alpha Over' in the strip Blend mode and have tried different formats when rendering the video (from QT to PNG to FFMPEG #1) but no matter what I try I still get black where the transparent areas are supposed to be. The only thing that has worked is outputting a series of PNG images and importing them as an image sequence into VSE. Is this a bug in VSE or am I doing something wrong? I've tried looking at the video strip settings and playing with that but I can't seem to get the transparency layer to work. I searched for answers and couldn't find anything specific to my issue where I'm using Blender to create the video with RGBA and it still doesn't work when importing to Blender VSE.

I am using Blender version 3.0.0 with an M1 Mac.

$\endgroup$
3
  • $\begingroup$ if u provide a blend file, i will check it out $\endgroup$
    – Chris
    Jan 27, 2022 at 15:17
  • $\begingroup$ Thanks for the offer! I've found that the issue seems to be with the previewer only. When I render the file then everything renders as expected. Not sure why the previewer doesn't show the transparency in the video strip? $\endgroup$
    – Ashmanq
    Jan 27, 2022 at 15:36
  • $\begingroup$ you can write your own answers here, if you want to. Then other people can read it too and can find the solution ;) $\endgroup$
    – Chris
    Jan 27, 2022 at 15:37

1 Answer 1

0
$\begingroup$

If one deactivates the Use proxies feature in the View Settings, the preview shows the alpha blending as expected.

$\endgroup$
2
  • $\begingroup$ Hello and welcome. This site is not a regular forum, the answer section is reserved exclusively for answering the OP question. To ask for clarification, post comments or replies please use the comments section instead. If you have the same problem or a different question please use the Ask Question button at the top right. If you want to add additional information or further developments, use the edit button below the original post instead. This post may be removed or converted to a comment. $\endgroup$ Jun 8, 2022 at 17:14
  • $\begingroup$ Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center. $\endgroup$
    – Community Bot
    Jun 9, 2022 at 3:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .