0
$\begingroup$

I don't know why but when try to use the texture paint mode it just doesn't work properly. When I paint in the image editor the 3d viewport result gives me a color which is a mixture of the colors in the image editor and when I try to paint in the 3d viewport, instead of affecting the area of where I paint it affects the entire object like it gets a light layer of the color which I try to paint over the texture.

I am a beginner so it will be really helpful if location of where the diagnose this problem is also mentioned

(sorry for my bad English)

I hope these images help

Pic 1 is the base texture I have

Pic 2 is what happens when I try to do something in the image editor

Pic 3 is what happens if I click or try to do something anything in 3d viewport

Edit: Here is the blender file if anyone needs it:

Pic 1 is the base texture I have

Pic 2 is what happens when I try to do something in the image editor

Pic 3 is what happens if I click or try to do something anything in 3d viewport

$\endgroup$
3
  • 1
    $\begingroup$ Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking. $\endgroup$
    – Community Bot
    Jan 27, 2022 at 14:49
  • $\begingroup$ Can you post the UV maps? $\endgroup$
    – Wolfeius
    Jan 27, 2022 at 17:36
  • $\begingroup$ You can upload a blend file here: blend-exchange.com. $\endgroup$ Jan 28, 2022 at 5:00

1 Answer 1

1
$\begingroup$

I think the problem results from using "color" in your brush options. Probably if you switch to the first option, "mix" you will have different results.

Steps

Otherwise, you can run through some steps again:

Open the shader editor so you can clearly see what materials are being added, and click use nodes. Open the UV editor on the left so that you can see where your material is mapped on the object.

In edit mode, unwrap the object by selecting the mesh and pressing U.

Then with the object still selected go to the Material Properties tab and assign it a new material. Change the material color to make sure it is working. You should see it in your shader editor.

enter image description here

Now switch to texture paint and click on the plus sign to add a texture paint slot. This is your base color. Complete the options, and you should now see an image appear in your node tree which you will be painting on. Keep it selected.

enter image description here

With the new material selected in your node tree, and the image open in your UV editor you should be able to paint as you like.

enter image description here

$\endgroup$
8
  • $\begingroup$ I did everything you said but it didnt work. I even created anoter similar object it still didnt work. Apparently this happens everytime when i import a 2d object and then use it to make a 3d object. $\endgroup$ Jan 28, 2022 at 3:57
  • $\begingroup$ That is strange. So this only happens with 2D objects? $\endgroup$ Jan 28, 2022 at 4:49
  • $\begingroup$ yes and now just left it like that (i didnt try it with other 2d objects but it only happened with this one which i did twice as a seperate object) $\endgroup$ Jan 28, 2022 at 5:08
  • $\begingroup$ I tried with other 2d objects which I transformed into 3d, i finally noticed that when i try to paint it only registers to the faces the object had while in its default state, so when i try it with a square i can paint only on the top and the bottom not the sides, and since the circle had no faces it shows that problem $\endgroup$ Jan 28, 2022 at 5:24
  • 1
    $\begingroup$ @common_goldfish, and everyone else, thak you for helping me $\endgroup$ Jan 29, 2022 at 4:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .