2
$\begingroup$

There is similiar questions but I couldn't manage to get good answer.Viewport

1st Viewport screenshot

2nd Render in Eevee They're both transparent don't mind that.

enter image description here

Tried tweaking World node as seen in one answer but couldn't get it right. Can't get inside of wheel, and especially balls, to look same. In viewport shading Scene lights are on, Scene world is off with studiolighting

enter image description here

$\endgroup$
2
  • 1
    $\begingroup$ hello please share the file $\endgroup$
    – moonboots
    Jan 27, 2022 at 10:45
  • $\begingroup$ I did, don't mind broken animation. Thanks! $\endgroup$
    – Radoon
    Jan 27, 2022 at 10:51

1 Answer 1

2
$\begingroup$

You need to reactivate your Scene World option in the Viewport Shading panel, otherwise it will be the Material Preview world that will been taken into account:

enter image description here

$\endgroup$
4
  • $\begingroup$ Thanks, tried that, but then my viewport is same as render. But I want my render to be like viewport. As seen on my first screenshot in my question. $\endgroup$
    – Radoon
    Jan 27, 2022 at 12:07
  • 1
    $\begingroup$ In that case you need to use the same HDRI used in Material Preview, check this answer: blender.stackexchange.com/questions/158336/…. $\endgroup$
    – moonboots
    Jan 27, 2022 at 12:27
  • $\begingroup$ Thank you. Now I see $\endgroup$
    – Radoon
    Jan 27, 2022 at 13:42
  • 1
    $\begingroup$ Or, do a viewport render. $\endgroup$
    – Nathan
    Feb 23 at 21:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .