3
$\begingroup$

I have a scene with a warped plane acting as a lens. I matched the camera to viewport, but the renders look too zoomed in, and the warping effect is different than in viewport.

Viewport render: Viewport

Renders: enter image description here

Note: I have tried messing with camera settings to no avail. Thank you for taking a look at the .blend file.

$\endgroup$
5
  • $\begingroup$ there is no blend file... $\endgroup$
    – Chris
    Jan 27 at 5:32
  • $\begingroup$ I apologize for that. The .blend file is now added! $\endgroup$
    – H01
    Jan 27 at 5:35
  • 1
    $\begingroup$ not sure about your material, don't you want to directly plug the glass into the Output? $\endgroup$
    – moonboots
    Jan 27 at 7:31
  • 1
    $\begingroup$ @moonboots I would think the same. $\endgroup$ Jan 27 at 8:16
  • $\begingroup$ You are correct; the material is overcomplicated for this particular shot. Thank you! $\endgroup$
    – H01
    Jan 27 at 11:50

1 Answer 1

5
$\begingroup$

Your "Edited Lens" object has a Solidify modifier that is disabled in the 3D Viewport. Without solidifying this object is just a plane, and in this case everything below is treated as if it was inside a big glass cube instead of a glass pane, because the IOR refracts the light while entering the plane from one side but not exiting on an opposing side.

If you enable the Solidify modifier in the viewport, the result looks exactly like the render. So the solution will be to deactivate the modifier for rendering as well - or simply delete it. If you don't want to see it neither in viewport nor in render, what good is it for?

$\endgroup$
1
  • 2
    $\begingroup$ Thank you very muh! I totally missed that. I am getting the results I want now. $\endgroup$
    – H01
    Jan 27 at 11:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.