6
$\begingroup$

I am new to rendering in Blender

enter image description here enter image description here

My rendering tab shows this: enter image description here

The problem here is that the lighting in the viewport is different from the output, and I can't understand why.

And this is the render: enter image description here

$\endgroup$
9
  • $\begingroup$ I am not sure what are you asking and what is the problem, output menu is same for both cycles and eevee. What exactly is the problem? $\endgroup$
    – MikoCG
    Jan 26 at 12:29
  • $\begingroup$ hello, where do you see any mention of Cycles in the Output? $\endgroup$
    – moonboots
    Jan 26 at 12:39
  • $\begingroup$ I see the rendering is completely different from the one you can see here, and this is in Eevee, while if I use Cycles, I get the same view I get in the output file, without lights. $\endgroup$
    – PolyMad
    Jan 26 at 12:43
  • 1
    $\begingroup$ The lighting you see in the viewport is just for preview, it won't affect your render, you can check Scene Lights and Scene World from Viewport Shading if you want your viewport render to look like your final render. $\endgroup$ Jan 26 at 13:22
  • 2
    $\begingroup$ Does this answer your question? Render looks way different from viewport render mode. How can I fix this? $\endgroup$
    – pyCod3R
    Jan 27 at 16:15

1 Answer 1

10
$\begingroup$

Okay, so the thing is, what you're viewing in the viewport, that's Material Preview Mode. In Material Preview Mode, blender applies a default HDRI (World Lighting) so that we can see the materials without any lighting.

Then comes Rendered Dispay mode, there we're supposed to add in lights and everything, so that we, the user have full control. But, if you want the lights from Material preview mode to carry over to Rendered Display mode, all you have to do is uncheck scene lights and scene world from the dropdown next rendered display icon on the top right, as shown below.

enter image description here

If you want to render it in as well, all you have to do is go to the Shader editor, and switch it from object to World

enter image description here

Add in an enviroment texture node by shift + A and searching Environment Texture, then click on open.

enter image description here

Navigate to where you've installed blender, and go to the relative data path mentioned below.

Blender Foundation\Blender{Version}\{VersionNumber}\datafiles\studiolights\world

There you can find all the HDRI's blender use. The default one should be Forest.exr

Load it up and connect it to the Background node. Now you should be able to render it in.

$\endgroup$
4
  • $\begingroup$ But still, simply unchecking Scene Lights and Scene World in the Render Viewport Shading will not use the preview lighting when it comes to a real render after you press F12. $\endgroup$ Jan 26 at 14:32
  • 1
    $\begingroup$ Updated the current answer to include that as well, thank you for pointing it out. $\endgroup$
    – Aswin
    Jan 27 at 15:46
  • $\begingroup$ Thank you, I solved and understood everything (I think lol). $\endgroup$
    – PolyMad
    Jan 28 at 21:51
  • $\begingroup$ If you have any doubts regarding this, please feel free to ask. Always happy to help. $\endgroup$
    – Aswin
    Jan 29 at 16:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.