0
$\begingroup$

https://drive.google.com/file/d/1E-bp_KgPw4jJ00nIL8FK5t6-zCE6Rx2u/view?usp=sharing video

from what I can tell it is only happening in Blender, it works perfectly in UE4( Gyazo link: https://gyazo.com/3484fbdfa972cec1b64a925a68434a18 )

the neck base is the only thing that has weights on the lower neck, yet the last spine bone has full control over it?

edit: nvm i found the problem lol, it was because i forgot to give it bendy bones while i gave it's surroundings bends

$\endgroup$
1

1 Answer 1

0
$\begingroup$

You might have the throat area assigned to more than one bones, and the total of weights higher than one. Some softwares and export files simply don't support that, so either your exchange format or UE might have tried to fix that as best as it could.

If you go in edit mode and select a vertex, you can see all the weights assigned to that vertex and their respective strenght:

vertex weights

Make sure there are only the weights you need, and the total doesn't exceed 1. That's what's called "normalization".

Alternatively, in weight paint, you can Shit RMB the mesh to see and select the weights available where you clicked:

weight sample

If you have Auto Normalization enabled, you can just paint that area, and Blender will make sure that whatever weight you add in a group is removed from the other groups so the total is always 1.

auto normalization

And finally, if you don't want to manually normalize, you can make blender do it (but make sure to check the result afterwards):

normalize

$\endgroup$
1
  • $\begingroup$ thanks for the info :) actually my problem lied within the bendy bones as i found out $\endgroup$
    – Skinny
    Commented Jan 23, 2022 at 2:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .