1
$\begingroup$

I am trying to make my own Jenga tower with blocks sliding out to practice rigid body simulations. When my blocks fall, they are interacting with the bottom of the plane but slide right through the beveled mesh. The plane, as well as the blocks, are set as rigid bodies and the blocks are active while the plane is passive. Here is the blend file if anyone wants to take a closer look. https://www.dropbox.com/s/iwyg5bh0otwjx9l/JengaBlockCopy.blend?dl=0 enter image description here

$\endgroup$

2 Answers 2

0
$\begingroup$

I'm assuming you did the simulation when that plane was flat, then you baked the simulation and then edited the plane to have a bevelled wall. To fix this, go to the Rigid Body cache, delete the bake, and re-bake. Make sure the plane Shape option is set to Mesh and not Convex Hull.

enter image description here

enter image description here

$\endgroup$
2
  • 1
    $\begingroup$ Hmmm, I did exactly what you said and the blocks still slid right through the curved edge. $\endgroup$
    – Mokruhl
    Jan 22, 2022 at 22:10
  • $\begingroup$ Nevermind! I had to add a solidify modifier to the plane! Thanks for the help! $\endgroup$
    – Mokruhl
    Jan 22, 2022 at 22:13
0
$\begingroup$

Change to shape "mesh" and "deform"

enter image description here

result:

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .