3
$\begingroup$

I currently have a texture on a pre-existing model that is 4096 x 4096 pixels. When I export a gltf file this texture is about 28 megs. Pretty big for what I want to do. There's also some other ones. I attempted to resize it by going to Image Editor -> image -> resize

enter image description here

Here I resize it to 1024 x 1024 and hit ok. The image appears smaller on the image editor and the size says 1024 x 1024. However when I save this or export it then it reverts back to the original image size of 4096. Is there something I'm doing wrong? Or another step I need to reduce these images sizes?

$\endgroup$
1
  • 1
    $\begingroup$ Interesting case. The glTF exporter depends on the dirty flag to know if the image has changed. If it hasn't changed, it will use the data from the file on disk. But resizing an image does not set the dirty flag... If you "Save As" the image after resizing, it should work though. $\endgroup$
    – scurest
    Jan 21 at 21:25

1 Answer 1

5
$\begingroup$

Once you have resized your image, make sure you save the image within the Image Editor/UV Editor panel. Image > Save or Save As.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.