2
$\begingroup$

Please bare with me as I'm a beginner with blender.

So I have a knob that I'm trying to animate. I need to rotate it 360 degrees around the y axis of the cursor. I set the rotation orientation to 3d cursor, I set the object origin to 3d cursor and I set the transform orientation and transform pivot point to 3d cursor. When I rotate it with the active tool it gives me exactly the result I want but when I add key frames the animation wobbles around what I think is the original origin orientation. How can I make the animation rotate around the cursor instead of any other axis?

Here is an example file: Example File

Any help would be greatly appreciated. Thank you.

$\endgroup$
1
  • $\begingroup$ Hello and welcome. While files, images, and external videos or links may be helpful additions they should not be the only way to obtain information about your issue. Don't make understanding your question rely on downloading a file, watching a video or visiting an external site. Use the builtin tools to upload images or gifs, along with thoroughly explaining the problem in written form so it can be indexed and searched for thus helping future visitors with similar issues. $\endgroup$ Jan 19, 2022 at 18:09

1 Answer 1

1
$\begingroup$

When I open your file, I see an object that has rotation that is only significant in its Y axis. But when I enable the display of object axes, I see this:

enter image description here

That Y axis is not in line with the axis that we want to rotate, so we have wobble.

Really, here, we don't want to rotate about a cursor (rotation about the cursor isn't the same as rotation about an object origin.) And we don't want to rotate in some special view axis either (because we're using Euler angles, we want our rotation to be aligned with our axes.) So we need to fix the axes of this object.

Enter edit mode. Change to a "normal" orientation (instead of "cursor" on top of your 3D view.) Select the center vertex of your knob, snap cursor to selection (shift s for me), and use "create orientation" operation (ctrl alt space for me). Your orientation will change from "normal" to "vertex"-- it now represents the normals of that vertex.

Now leave edit mode. On sidebar/tool/affect only, enable "origins". On the object menu, use object->transform->align to transform orientation. Then use object->set origin->origin to 3D cursor. You now see that your origin lies at the vertex we selected (which we selected because it ought to be the middle of the knob), and that our axes have changed. They're aligned, but they're aligned with Z. Because we already are affecting only origins, we can rotate in the X axis by 90 degrees to get the Y axis pointing out, like you wanted:

enter image description here

Take a look at your animation. The wobble is gone. Don't forget to turn off affect only origins for future work, or it might be very confusing until you remember that....

$\endgroup$

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .