I'm struggling to model with curves today. I can't seem to scale the curve without making the object curve so tiny I can't even see it? enter image description here

To get the curve size I want, the target object is a speck on the screen. enter image description here

Has this been updated since last I used it? 2020 How do I scale without having a speck on my screen?


1 Answer 1


When you scale a curve, it also scales it's vertex radius.
And vertex radius affects bevel size.

Simply tab to edit mode and set Mean Radius back to 1.

enter image description here

  • 1
    $\begingroup$ Excellent thanks @jachym, super helpful.... what a nice little place to hide that setting. $\endgroup$
    – CromeX
    Jan 18 at 16:06
  • $\begingroup$ no problem :). The first time i got stuck on this I also went here to get help :)) $\endgroup$ Jan 18 at 17:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.