1
$\begingroup$

I'm trying to make a little hairy creature walk around with googly eyes. But I have an issue with my hair particles going through the eyes.

The eyes are made out of an animated rigid body "case", and a black rigid body cylinder which acts as the pupil.

I've weight painted the ball, to avoid hair growing in the eyes, but hair above and around still goes through them on movement.

Hairs through eyes Is there a way I can avoid this?

Thanks in advance.

$\endgroup$
1
  • 3
    $\begingroup$ Try adding a Collision Modifier in the physics tab for the eyes. You might need to tweak the physics settings to get the right result. $\endgroup$
    – Benus
    Commented Jan 18, 2022 at 5:06

1 Answer 1

3
$\begingroup$

As Benus wrote in the comment, just add a collision modifier to your eyes.

Result:

enter image description here

Right eye: with collision modifier added.

Hairs and softbodies do not react on rigid bodies. They need a collision modifier to be recognized as effector objects.

BTW: nice pimp up of Polyfjords model! ;)

$\endgroup$
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .