0
$\begingroup$

I have a problem with final render of the room because it is completely different from one in the viewpoint render. There is no HDRI lightning and HDRI background is white.

Thank you for your answers I really need your help.

Final render without HDRI lightning and background

$\endgroup$
3
  • $\begingroup$ Hi, congrats on your first question here! If my answer below doesn't answer your question then a few more details could be helpful, such as if you're using Cycles or EEVEE, if you're using the Compositor, or a screenshot of the viewport you mentioned (showing the surrounding settings). Also, it's often a good idea to post your blend file, or a truncated version of it that has the problem. The Blender StackExchange has its own service to share blend files: blend-exchange.com/help $\endgroup$
    – KickAir8p
    Jan 14 at 21:35
  • $\begingroup$ Thank you for your answer, bit this doesn’t solve the problem. My world shader was set correctly. I tried changing HDRI, rendering without windows.. I would share my blender file but it is 500mb so it doesn’t want to convert in link. I am using Cycles. I can post screenshots of my settings. $\endgroup$
    – Nejc3333
    Jan 14 at 23:08
  • $\begingroup$ Looking forward to the screenshots -- you might consider making a truncated (maybe delete everything in the room) save of the blend file to make available for us. $\endgroup$
    – KickAir8p
    Jan 14 at 23:40
0
$\begingroup$

If your HDRI isn't showing in your final render then you probably don't have it set up correctly in your World Shader (Shader Editor > Shader Type: World). This example is in Cycles, and the only lighting is one of Blender's included HDRI's (sunrise.exr) in the Environment Texture node:

enter image description here

An easy to miss cause of this (or similar) problem is to use the Image Texture node instead of the Environment Texture node for the HDRI file.

$\endgroup$
1
  • 1
    $\begingroup$ It's also possible that you have the Transparent option checked in Render Properties although that should give you a black background. On the Properties sidebar, click the Render Properties (Computer) icon, scroll down to Film and open that tab with the down arrow. There is a Transparent checkbox which should be unchecked if you want to see the HDRI scene in the render. With it checked you'll still get the ambient light from the HDRI scene in the render, but won't see the actual background scene that produces it. $\endgroup$
    – John Eason
    Jan 15 at 0:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.