1
$\begingroup$

I have several collections and noticed that whenever I move an object (that I have already rigged and animated) from one collection to another, the keyframes dissappear from the dope sheet and the time line. The animations i made are still there but the keyframes are gone. Also my summary is empty. I've searched the internet and haven't found anything, neither scrolling up nor 'show hidden' helped. Does anyone know how to get my keyframes back?

enter image description here

$\endgroup$
5
  • $\begingroup$ If the collection is disabled (The checkbox column checkbox is deselected) then the keyframes won't show up in the editor, even with show hidden selected. $\endgroup$ Jan 10 at 18:27
  • $\begingroup$ @MartyFouts the collections in which the items are are selected in this screenshot; also if i select all collections i still can't see the keyframes $\endgroup$
    – Lisa
    Jan 10 at 18:37
  • $\begingroup$ Can you share a simplified Blend file that shows the problem? (How to add a blend file) $\endgroup$ Jan 10 at 18:42
  • $\begingroup$ Did you try right click on the collection name and choose "select objects"? Sometimes it refreshes the UI. $\endgroup$ Jan 10 at 19:03
  • $\begingroup$ i uploaded the file to the question @MartyFouts :) @ josh sanfelici i did and it didnt help :') thank you two already for trying to help! $\endgroup$
    – Lisa
    Jan 10 at 19:24

1 Answer 1

1
$\begingroup$

Found it. Sorry it too so long. You have filters enable. Select the filter drop down in the dope sheet and you will see this:

fitler dropdown

I've highlighted Collection in red. The filter is preventing you from seeing any animation data except for object in Collection collection. Click the 'x' and you'll be able to see everything.

$\endgroup$
2
  • 1
    $\begingroup$ Ahh it was so easy, thank you so much!! made my day $\endgroup$
    – Lisa
    Jan 10 at 23:24
  • 1
    $\begingroup$ Glad I could help. Wish I'd thought of it sooner. $\endgroup$ Jan 11 at 2:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.