0
$\begingroup$

Blender version 2.93 will correctly render a grease pencil layer, regardless of stroke depth order, behind a 3d object that is closer than the grease pencil layer.

enter image description here

Blender version 3.0.0 incorrectly renders the grease pencil layer in-front of the 3d object regardless of the stroke depth order. enter image description here

I've uninstalled a September 2021 installation of 3.0.0 and reinstalled the most current distribution.

Am I missing anything? Does anyone have a solution or work around for this apparent bug?

$\endgroup$
2
  • $\begingroup$ Have you checked if that bug is already reported, and if not, posted a bug report? $\endgroup$
    – Lauloque
    Commented Jan 6, 2022 at 14:44
  • $\begingroup$ I will do that. $\endgroup$
    – bigLarry
    Commented Jan 6, 2022 at 15:04

2 Answers 2

1
$\begingroup$

I see the answer at your screenshot:

enter image description here

I'm pretty sure that you have z pass disabled:

enter image description here

$\endgroup$
1
  • 1
    $\begingroup$ Seems that in 3.0.0 by default View Layer Properties>Passes>Data Z is set to false while in 2.93 it is set to true. $\endgroup$
    – bigLarry
    Commented Jan 6, 2022 at 16:44
0
$\begingroup$

I'v got another trouble. Grease pencil, that were posted behind the 2d png picture, overlapped it. That was solved buy changing Blend Mode from "Alpha Blend" to "Alpha Hashed" into png Material properties -> Settings.enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .