4
$\begingroup$

I have a particle system that uses a mesh as an emitter. It emits from the Vertices in a non-random order, and (I assume) it uses the vertex index to determine that order.

It works as intended, with the particles appearing in an orderly fashion, except for one thing: the top line appears first, then it starts from the bottom and makes its way to the top.

enter image description here

(Notice how the top line is already there and the rest of the particles are still appearing from bottom to top)

I don't want the top line to appear first. I want it to start from the bottom and work its way to the top, and the top line is the last one that should appear. For that I guess I need to change the indices of the top vertices so they are last and not first. Any way I can do that? It can be manually, although I would prefer an 'automatic' solution.

Thanks.

$\endgroup$
2
  • $\begingroup$ Have you tried deleting this row in edit mode and re-extruding it ? $\endgroup$
    – Gorgious
    Jan 6, 2022 at 14:00
  • $\begingroup$ Yes, but it didn't work. The particles still spawn in the top line first. $\endgroup$ Jan 6, 2022 at 14:04

1 Answer 1

11
$\begingroup$

Try to MeshSort elements and then try available options. I suppose Reverse is that you are looking for.

enter image description here

$\endgroup$
1
  • $\begingroup$ I had to try a few options but eventually one worked as intended. Thanks! $\endgroup$ Jan 6, 2022 at 14:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .