enter image description here

Link to Donut (Blender File): https://drive.google.com/file/d/19oO2U4yoS58DcYH9T-to6EJgbEM-nYb-/view?usp=sharing

Doing Blender Guru's recent donut tutorial and am having issues with pixelation around the ring of my donut. I am using motion blur, however, turning it off does not remove it fully so I am not sure what is causing it.

Motion Blur Settings

  • $\begingroup$ Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking. $\endgroup$
    – Community Bot
    Jan 5, 2022 at 4:41
  • $\begingroup$ please provide your blend file so we can check it out. It's not the fault of the tutorial...so this won't help here...And because you show us no settings at all we can just guess around. Try to give as much detail/information as possible so we can help you. Just a picture of the end result helps only in some special rare cases. $\endgroup$
    – Chris
    Jan 5, 2022 at 6:33
  • $\begingroup$ @Chris I added my motion blur settings, the google drive link is the blender file. $\endgroup$
    – Sammy262
    Jan 5, 2022 at 18:43

1 Answer 1


It looks like a bug, your render seem to stop rendering after a certain amount of time even though your time limit is already set to zero.

As a consequence, Blender barely has time to render, resulting in a very noisy image, which is denoised on the beauty pass but not on the alpha pass, hence the pixelisation look.

To fix this, try to click it and manually type 0 and hit ⏎ Enter. It works on my side.

demo fix

I'd also report this as a bug via File → Report a Bug so it can be fixed for the next version.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .