1
$\begingroup$

This is something i just encountered while using Blender with Windows

Whenever i use Blender my keyboard layout changes from german to english or something similar. This is rather annoying because most of the special characters are in different places and the Z key is swapped with Y.

This isnt a problem that then only occurs in Blender. Infact, i am even writing this with the wrong keyboard layout right now.

I am very confused as to what could cause this and why it happens and most imoprtantly, how to fix it?

$\endgroup$
4
  • 3
    $\begingroup$ Most likely you press Alt+Shift by accident, which is a Windows shortcut to switch the language (not related to blender): superuser.com/questions/698037/… $\endgroup$
    – p2or
    Jan 4, 2022 at 14:59
  • 1
    $\begingroup$ thank you, will look into it (great how windows just doesn't give you an update at all when your keymap changes -.-). but yeah. apparetnyl ctrl + shift and alt + shift are hotkeys to switch the keyboard language and those are very present hotkeys in blender altough i wasnt able to reproduce the issue rn. will see if it fixed it $\endgroup$
    – rafe
    Jan 4, 2022 at 15:05
  • 1
    $\begingroup$ @p2or Could you post that as a answer? Please ping me in the comments if you do for an upvote $\endgroup$ Jan 13, 2022 at 11:04
  • $\begingroup$ @DuarteFarrajotaRamos i posted an ansewr ;) $\endgroup$
    – rafe
    Jan 13, 2022 at 15:28

1 Answer 1

3
$\begingroup$

The problem wasn't related to Blender per se but more an action that you frequently do in Blender. When you hit Alt + Shift under Windows operating systems it will change your keyboards layout.

You can turn this off by toggling a setting in windows. It is explained in this post: https://superuser.com/questions/698037/can-i-disable-the-altshift-shortcut-to-change-language-in-windows-8-1-or-win :

  1. Press the Windows key, type Advanced keyboard settings and then press Enter
    Windows Search for 'Advanced Keyboard Settings'
  2. Input language hot keys (left)
    Select 'Input language hot keys'
  3. Change Key Sequence... (for "Between input languages")
    Select "Advanced Key Settings" tab, and press "Change Key Sequence"
  4. Set to "Not Assigned"
    enter image description here
$\endgroup$
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .