0
$\begingroup$

I followed a tutorial to get a milk-like texture but I wanted it in an orange color, when I applied the same settings to my texture there is now a blue tint in the material. Can someone explain why this is happening? Is this also related to Subsurface Scattering? In the first image is my material preview, I believe the surface radius relate to RGB value which should mean that it should be more red than blue right?

I've disabled mix shader and glossy shader but it seems that didn't fix the solution. The last image is of just the liquid with a subsurface of 0.1 with the cup turned off and the edges seem to be clear white

enter image description here

enter image description hereenter image description here

$\endgroup$
1
  • 2
    $\begingroup$ Hi :). Your Scattering depth is 10x larger than should be for milk. This can cause blue tint, because physics. $\endgroup$ Jan 3, 2022 at 23:42

1 Answer 1

0
$\begingroup$

Mute your Mix Shader and see if the problem goes away.

My suspicion is that since the Principled BSDF already has a glossy component, mixing in another Glossy BSDF is messing up the light response.

If you need more gloss, try using the Clearcoat setting on the Principled BSDF.

enter image description here

VS

enter image description here

$\endgroup$
5
  • $\begingroup$ thank you I will definitely do that. I did disable the mix shader and glossy shader but there still seems to be the blue tint @allensimpson imgur.com/a/yXLhSsz imgur.com/a/VOXljXX $\endgroup$
    – jk123
    Jan 3, 2022 at 19:19
  • 1
    $\begingroup$ @jk123 Seems like that is coming from the plastic shader and not the liquid. $\endgroup$ Jan 3, 2022 at 19:29
  • $\begingroup$ Here is my render with subsurface at 0, 0.1, and 0.5. I also included a last render that has a subsurface of 0.1 but with no cup and it seems that the edge is clear. Is this what's causing the blue tint and how could I fix that? $\endgroup$
    – jk123
    Jan 3, 2022 at 19:45
  • 1
    $\begingroup$ @jk123 please edit your question and add new images there. The comments are not always completely visible and not everybody reads them all. -- Blender 3.0 uses the "Random Walk" option by default. This uses the thickness of the mesh to calculate the SSS. If the mesh is too thin (the plastic?) then you can get this blue-ish color. Try the "Christensen-Burley" option and see if it's still blue. $\endgroup$
    – Blunder
    Jan 3, 2022 at 19:47
  • 1
    $\begingroup$ @Blunder I have some similar model here, the bluish tint also appears if you render only the drink inside without the plastic cup. It's like you say, "Christensen-Burley" does a better job. Also "Random Walk (Fixed Radius)" is better than the default "Random Walk". And I just realized "Christensen-Burley" renders much faster, the default "Random Walk" renders slowest. Never tried that. $\endgroup$ Jan 3, 2022 at 20:22

Not the answer you're looking for? Browse other questions tagged .