2
$\begingroup$

I was working on a model, and I wanted to edit some texture nodes. So I went to the node editor and switched to the texture tab, but there was no way for me to select the the texture:

Missing texture input

But when I switched to world texture, I was able to select a texture again.

Texture input shown

The problem wasn't solved after restarting blender. So I wanted to see what would happen if I loaded another file or created a new one. After doing this, I was able to edit object texture nodes:

New blend file

As you can see, only one blend file is being affected. Does anybody know what would be causing this or how it could be fixed?

$\endgroup$
  • 1
    $\begingroup$ did you check 'Use Nodes' otherwise you can't work with nodes in there $\endgroup$ – Chebhou Feb 16 '15 at 23:23
  • 2
    $\begingroup$ @Chebhou As you can see in the first image, there is no option to use nodes. $\endgroup$ – Lysol Feb 17 '15 at 3:05
  • $\begingroup$ If you really think that this is a bug, then OK. But this is only affecting this particular blend file. $\endgroup$ – Lysol Feb 17 '15 at 6:26
  • $\begingroup$ This isn't a bug, it depends on certain steps. $\endgroup$ – sambler Feb 17 '15 at 8:05
3
$\begingroup$

The object texture list shown in the node editor is generated from textures used by Blender Internal render engine materials. A material and one of it's textures needs to be selected for this list to show up even though every available texture will then be listed.

These texture slots are only accessible when the Blender Internal render engine is active.

This means that the texture slots need to be created while Blender Render is active, if Cycles is chosen after the slots are populated then the list will still be visible in Cycles, though they will have no use for the material. Materials created while Cycles is active will not have any material slots and will not show the list in the node editor.

$\endgroup$
2
$\begingroup$

I think you are using cycles and trying to use the texture node editor which you can't do cause there is no way to use those texture in cycles ,so to use this node editor you should be using blender render

$\endgroup$
  • $\begingroup$ I opened a blend file which was set to cycles render, which did have this option available. $\endgroup$ – Lysol Feb 17 '15 at 3:05
  • $\begingroup$ To see the texture nodes with cycles you need to create the material in BI and add a material slot, then change to cycles. $\endgroup$ – sambler Feb 17 '15 at 8:08
  • $\begingroup$ @AidanMueller that's because you selected the default cube which already have a texture created in blender internal as sambler noted $\endgroup$ – Chebhou Feb 17 '15 at 9:39
  • $\begingroup$ I also did this without the default cube. I used a file that had suzzane and a plane. $\endgroup$ – Lysol Feb 18 '15 at 2:40
  • 2
    $\begingroup$ Even using BI you will find that node textures have no effect for the displace modifier, you need to adjust the standard texture settings. Node textures work for brushes and freestyle line textures even with cycles active so it shouldn't be too much work to make it work for modifiers. $\endgroup$ – sambler Feb 18 '15 at 13:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.