0
$\begingroup$

enter image description here

Hello. I am new to blender 3.0. I have started learning it from Andrew Price's(Also known as Blender Guru https://www.youtube.com/c/BlenderGuruOfficial/) Donut series. While learning from the series, I came across a something which isn't problematic as of now. But out of curiosity and in an effort to reduce future storms, I decided to find about it by googling it but didn't find any result.

What I want to know is what is the zig-zag pattern as shown in the image that appears in the edit mode?

What I have tried so far:

  1. Checking if there are overlapping meshes. I had done this using merge by distance.
  2. Flip the normals.
  3. Delete the modifiers and again use them.

Some Deatils: Modifiers used : Solidify, Subdivision Surface Blender Version : 3.0

Blend File

$\endgroup$

2 Answers 2

0
$\begingroup$

I would think this is because there is a subdivision surface modifier on the mesh which is also previewed during edit mode. The preview intersects with the edit mode 'cage' resulting in these patterns. It's display related and nothing to worry about in terms of mesh quality. Could be any other modifier as well(e.g. solidify)

$\endgroup$
2
  • $\begingroup$ Sorry for replying late. I had disabled subdivision surface, solidify in edit mode. I guess they can't be the troublemakers. $\endgroup$ Jan 2, 2022 at 16:09
  • $\begingroup$ Disabling it in edit mode does not mean it disables the preview of the final surface. You can still see the solidify result. Try applying all modifiers. Then you should be able to see what your actual mesh looks like in edit mode. $\endgroup$
    – adegner
    Jan 3, 2022 at 23:16
0
$\begingroup$

Without a blend file you can sadly not say much about this. You can use blend-exchange.com to share your file.

My assumption here would be that your icing is clipping through the actual donut. Thats what causes those lines. Its where both start intersecting. This shouldn't be visible if you are in object mode because of the Solidify modifier which us disabled in edit mode (probaly for easier editing). This wont be visible in the final image. But if you would still like to have it fixed you could try to scale it up as a whole or move it slighly up on the Z axis.

$\endgroup$
1
  • $\begingroup$ Sorry for replying late. I have uploaded the blend file. I did what you said. Moving up did solve the problem at that place. But it gave rise to problem at other place. Scaling up didn't minimize the problem. After scaling up, vertices of some inner rows disappeared as if they had had gone behind the donut surface touching that part of icing. $\endgroup$ Jan 2, 2022 at 16:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .