7
$\begingroup$

I seem to be locked into Object Mode. When I hit Tab, Blender won't switch into Edit Mode.

Why is this happening? And how do I fix it?

$\endgroup$
7
  • 4
    $\begingroup$ Do you have a mesh selected? $\endgroup$ Commented Feb 16, 2015 at 3:31
  • $\begingroup$ Have you linked the object from a different Blend? $\endgroup$
    – Humilton
    Commented Feb 16, 2015 at 3:44
  • $\begingroup$ Maybe your curserposition is in another view. 1) Click inside the viewwindow and 2 ) then press tab to toggle between object and edit mode. $\endgroup$
    – Noli-me
    Commented Feb 16, 2015 at 13:41
  • $\begingroup$ I copied and pasted an object from a different Blend. Maybe that's why it was locked. But why is that? $\endgroup$ Commented Feb 16, 2015 at 14:04
  • $\begingroup$ As you can see, this could be caused by several things. It would be great if you could upload you Blend-file. Use this link: pasteall.org/blend $\endgroup$
    – Humilton
    Commented Feb 16, 2015 at 14:46

7 Answers 7

9
$\begingroup$

I copied and pasted an object from a different Blend. Maybe that's why it was locked. But why is that?

If you link an object from another file, it can only be edited in that file, not the one you have added it to. What Blender is doing is making an exact copy of a portion of another .blend file, and reverse connections are not currently supported (being able to update the linked .blend). You will need to Import the mesh in order to edit it.

Changes to the source .blend file will not be automatically visible in the linked mesh, you will need to re-link or update the mesh.

$\endgroup$
1
  • $\begingroup$ How do I import from another .blend file? $\endgroup$ Commented Sep 27, 2019 at 22:46
7
$\begingroup$

Make your object local:
Object > Make Local > All
or CtrlL

Or unlock in the outliner

$\endgroup$
4
  • $\begingroup$ what is "unlock the outliner" ? $\endgroup$
    – jsbueno
    Commented Feb 19, 2019 at 20:01
  • 2
    $\begingroup$ Where is "Make Local" in Blender 2.8? $\endgroup$ Commented Sep 27, 2019 at 22:47
  • 1
    $\begingroup$ Select the object, then Object -> Relations -> Make Local (and choose one of the options under that). $\endgroup$ Commented Sep 9, 2020 at 4:01
  • $\begingroup$ Thank you @SeanRobertson $\endgroup$ Commented Dec 12, 2020 at 0:40
4
$\begingroup$

The object might be linked in another scene within the same file. Switch to the proper scene prior to editing the object.

For instance, in the Barcelona Pavillion demo file from https://www.blender.org/download/demo-files/ There is a chair object. In a regular scene (midday/sunset/night in this dataset), edit mode won't be available for the chair.

You have to switch to the "assets" scene and the proper layer, then RMB to select the chair for edit mode to be available.

$\endgroup$
1
$\begingroup$

If you have no object selected, Edit mode is not available, even if your scene contains only one object! The workaround is to select the object by clicking on it with your Select mouse button. The purpose of Edit mode is to edit the mesh (components) of an object, so one must be selected. Then Edit mode applies only to that selected object.

$\endgroup$
1
$\begingroup$

In Blender 2.8 make the object local going to Object > Relations > Make Local > All

$\endgroup$
1
$\begingroup$

Under Edit there is a button called Lock Object Modes. I just unticked that and it worked.

$\endgroup$
0
$\begingroup$

In Blender 2.8, make sure you're in the Modeling workspace. You may have inadvertently switched to one of the other workspaces such as Layout. The workspaces are selected using the buttons in the menu bar along the top edge of the screen, or by pressing Ctrl+PgDn or Ctrl+PgUp

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .