1
$\begingroup$

I am struggling to understand what is happening to this asset pack I have downloaded. I save the blender file and then import into unity but it seems to be inverted and the model looks see through. Any ideas on what I am doing wrong?

This is the asset pack I originally downloaded. https://hexagon6.itch.io/sci-fi-tower-defense-pack

What the model should look like. (blender) In unity.

##EDIT##

I figured out the issue.

You need to ensure that this button is clicked and then select the dropdown arrow and enable "Backface Culling".

When you have done that you then select the mesh, press "tab", press "a", then press "shift + n" this should recalculate the faces and then the model displays correctly in unity.

Options

$\endgroup$
2
  • $\begingroup$ Link to source of information google.com/… $\endgroup$
    – Chris Lowe
    Commented Dec 28, 2021 at 21:05
  • $\begingroup$ If you found the solution to your problem, it is better to post it as an answer to your question to help people who have the same problems. $\endgroup$ Commented Dec 28, 2021 at 21:41

1 Answer 1

1
$\begingroup$

You can enable Backface Culling to view the model as in game engines like Unity...

  • For material/render preview by enabling the option in the material settings:

  • For solid view by switching to to ensure that this button is clicked and then select the dropdown arrow and enable .

Options

When you have done that and see through some faces, it means the normals are facing the wrong way - you then select the mesh, press Tab, press A, then press ⇧ Shift + N this should recalculate the faces and then the model displays correctly with Backface Culling (and so it displays correctly in game engines like Unity).

Youtube source

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .