1
$\begingroup$

I've been having this problem since I downloaded blender 3.0 (Final Release). Whenever I try to save my preferences, it shows: "Cannot save preferences" and "Cannot save old file with @".

Due to this problem, I cannot properly use any addons or any other preferences in blender 3.0. I have tried reinstalling blender, but the issue persists. I do not have any blender files with @ in them.

Please help. Thanks in advance (: enter image description here

$\endgroup$
12
  • $\begingroup$ I cannot remember where preferences are stored, but perhaps the folder or file is not writable permission. It sounds like it appended a '@' onto the filename. $\endgroup$
    – james_t
    Dec 27, 2021 at 22:20
  • $\begingroup$ @james_t so what am I supposed to do? $\endgroup$ Dec 27, 2021 at 22:21
  • 1
    $\begingroup$ As far as I know W11 isn't any different to W10 as far as folder permissions and locations are concerned so I'd try to find the userpref.blend file by typing '%USERPROFILE%\AppData\Roaming\Blender Foundation\Blender\3.0\' into the Windows Run dialog box and then opening the 'config' directory that it should list. In W10 Professional that opens fine here so I doubt it's a permission problem. I suspect you'll have to delete the 'userpref.blend' file there to get things running again but that may well delete any layout and theme options you have set up. $\endgroup$
    – John Eason
    Dec 27, 2021 at 23:04
  • 1
    $\begingroup$ @KickAir8p Maybe the problem is that I downloaded blender from the Microsoft Store, so instead, it might work if I downloaded it from the website $\endgroup$ Dec 28, 2021 at 20:10
  • 1
    $\begingroup$ Well, my problem was actually solved by uninstalling the Microsoft store blender 3.0 version and downloading the windows version of 3.0 from blender's website. Anyways, thanks for your time and help!) $\endgroup$ Dec 28, 2021 at 20:47

1 Answer 1

0
$\begingroup$

For me, the solution was to download blender 3.0 from its website. I originally downloaded blender 3.0 from the Microsoft Store, which was causing the "BLEND@" file problem. Uninstalling the Microsoft Store version and downloading blender from blender's website solved the problem.

Also, thanks for John Eason's and KickAir8p's help in the comments. The solutions didn't solve my issue but are the primary solutions for most problems like these.

$\endgroup$
1
  • 1
    $\begingroup$ How odd! The '@' character is certainly illegal in windows filenames so I'm not sure what could have caused it. At least you seem to be back in business now! $\endgroup$
    – John Eason
    Dec 29, 2021 at 0:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.