2
$\begingroup$

I have made a quick animation where an object fades, and I have animated a value to do this, however, I am not able to see my keyframes, both in the timeline and graph editor. The keyframes are still working though, and I can see the diamond in the material properties tab, and the animation working as expected in the viewport.enter image description here

$\endgroup$
2
  • 1
    $\begingroup$ Go to Shader Editor and select the node containing animated value. $\endgroup$
    – vklidu
    Commented Dec 26, 2021 at 22:38
  • $\begingroup$ Thanks a lot, is there any way that the keyframes can still be shown even when I don't have the node selected? $\endgroup$ Commented Dec 26, 2021 at 22:44

1 Answer 1

5
$\begingroup$

The problem is that by default, the timeline only shows keyframes from selected channels. In the case of your shader, this means that, even though the shader editor does not have to be visible, the node that you have the keyframes on has to be selected.

If you want to show all keyframes in the timeline, click on View and deselect Only Keyframes from Selected Channels:

Timeline View Menu showing Only Keyframes from Selected Channels

Note that the Dope Sheet and the F-Curve Editor have a different method for deciding whether to show only selected channels. There is a button with an arrow icon on the right of the header. Enabling it shows only selected channels:

Dope Sheet header showing "Only Show Selected" option.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .