1
$\begingroup$

I am quite new here and struggling to figure out why there are two places to control shading, and how to switch which one actually controls the shading. Also: what is the semantic difference between "material properties" and "shading" from blender's point of view?

  1. Layout tab > Properties > Material Properties > Material > Surface > Use nodes this one works, but here I am able to use a single node only

enter image description here

  1. Shading tab > Shader editor > Object I see a number of cool tutorials on how to use this one with multiple nodes. However, changing things here has no effect on the object shading. I clearly see that it refers to the object of interest "backsplash", still no effect.

enter image description here

$\endgroup$
9
  • $\begingroup$ Yeah something isn't right, there. The material output node should have a maroon colored header if it's the active output. $\endgroup$ Dec 26, 2021 at 21:34
  • 1
    $\begingroup$ Frame all nodes with the Home button and see if there aren't some extra nodes hanging around. $\endgroup$ Dec 26, 2021 at 21:35
  • $\begingroup$ @AllenSimpson how do I "frame all nodes with the Home button" -- are you talking about the Shader view? Where do I find "Home button"? $\endgroup$ Dec 26, 2021 at 21:36
  • $\begingroup$ Clicking on the header of the "Output" node in the Shader view made the header maroon, and now it seems to control the shading. Strange... $\endgroup$ Dec 26, 2021 at 21:39
  • $\begingroup$ On the keyboard :p - blender.stackexchange.com/questions/210908/… $\endgroup$ Dec 26, 2021 at 21:39

1 Answer 1

1
$\begingroup$

If both images are the same material:

  1. You should see only one node. The Material Output Node doesn't show up. If you want to add other nodes, you need to click on the circle in the Principled node that represents the input you want to connect and select from the popup. Here's an example of clicking on Base Color's Yellow node:

Clicking on the Base Color node

If I were to, say, select Brick Texture, then the Base Color input would change to

Base color showing Brick settings

and all of the Brick Texture settings would become available. I could click on the ↓ (down arrow) to "close" the Brick Texture panel.

You can edit everything this way but it becomes very difficult to follow.

  1. Your problem is that you have the 3D viewport in Solid Viewport Shading mode. That doesn't show your material. There are two Viewport Shading modes that do. See this answer for a detailed explanation.
$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .