0
$\begingroup$

enter image description here

I have a multi-part character model and after detaching parts the colors got screwed up and I can't figure out how to get them working. When I choose MMD shading - Shadeless, the textures show properly, but they look bad due to no shading. As such, I guess it's something to do with shading, but nothing I've tried has worked. Any help would be appreciated, thanks.

Edit: Found something else that might help? When I change the camera angle the ends of the arms/legs/neck all have this weird transparency with a shade inside that moves around as I adjust the camera angle.

enter image description here

enter image description here

$\endgroup$
5
  • $\begingroup$ You have checked the normals (face orientation)? The Auto Smooth option and Custom Split Normal Data can cause shading problems, too. Is there transparency used in the material? -- and what means "...after detaching parts...."? How have you detached the parts? $\endgroup$
    – Blunder
    Dec 25, 2021 at 3:19
  • $\begingroup$ I'm not too familiar with normals, but I tried flipping them and I also tried Recalculate Outside and Inside. None of them helped, they only managed to make it worse by flipping the inside to the outside. As for transparency, I don't have any transparencies attached as textures. For detaching parts, I separated the arms, legs, body and head via selecting the faces and using separate to make them their own objects. Even if I rejoin the parts, the shading doesn't fix itself, so that's not the issue. Although, the shading issues are where I separated the objects into their own object. $\endgroup$
    – Diablomarv
    Dec 25, 2021 at 6:12
  • $\begingroup$ Just to clarify, the files are .vb, thus why there are parts. $\endgroup$
    – Diablomarv
    Dec 25, 2021 at 6:15
  • $\begingroup$ Can you share a blend file with 2 pieces that have bad shading? (google drive or pasteall.org/blend - you need to post the generated link here after the update ) Otherwise, we have to guess a lot. If you join 2 meshes with Ctrl+J they become 1 object but the meshes are still separated. You need to merge them (M > Merge By Distance). Just saying. $\endgroup$
    – Blunder
    Dec 25, 2021 at 14:12
  • $\begingroup$ I'll share the blend file with just the relevant stuff, if you need more of the model/textures let me know. drive.google.com/file/d/1CdHdg9exZ82QP3ocCpSwf3a-pbyL3APy/… $\endgroup$
    – Diablomarv
    Dec 26, 2021 at 6:37

2 Answers 2

0
$\begingroup$

Preparation

First, you want to check what is Material.006 and if you still need it. In Edit mode, you can use the Select button below the materials list to check where a material is assigned. In this case, it's only the edge loops.

Merging the Meshes

To join the two mesh objects select them both and press Ctrl+J. The active mesh (highlighted in light orange) will be the main object and will become the new merged object with all modifiers.

To actually merge the meshes, switch the Edit mode, select everything A, and use M > Merge By Distance to do the merge.

merging the meshes

To check the result, unselected everything with Alt+A, hover the mouse over one merge mesh and press L to Select Linked. All visually connected mesh should be highlighted if the merge worked. (If it would fail, you need to adjust the merge distance. But this isn't needed here.)

Shading Issues (Auto Smooth + Custom Split Normals Data)

The shading issues are caused by edited split normals, so-called Custom Split Normals Data. If the Object Data Properties > Normals > Auto Smooth option is enabled Blender will use them for the shading. Imported meshes often have this extra data.

Turn Auto Smooth off to get rid of the shading issues, and use the Clear Custom Split Normals Data button in the Object Data Properties > Geometry Data section to delete the data permanently if you don't need it.

fixed shading

$\endgroup$
1
  • $\begingroup$ Yup, that fixed the issues, thank you very much! $\endgroup$
    – Diablomarv
    Dec 27, 2021 at 3:09
0
$\begingroup$

We lack the information about how you model is set up to pinpoint the problem. Shading inconsistencies can have many causes like, smoothing group issues, flipped normals, blend mode irragularities, shaprness seams, intersecting geometry.

$\endgroup$
2
  • $\begingroup$ Thanks, can you tell me what I would need to show to help figure it out? The only thing I knew to try was messing with normals, so that can be ruled out. $\endgroup$
    – Diablomarv
    Dec 25, 2021 at 2:08
  • $\begingroup$ It might be a material setting, check if the blend mode of your material is set to opaque and not alpha blend when you are using eevee. It can also be your roughness or specularity that changes the colors by reflecting your environment. Also sometimes your normal map can be set to sRGB which should be Non-Color and add a nomal map node after your normal texture. this can fix artefacts as well. $\endgroup$
    – Roel Deden
    Dec 25, 2021 at 13:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .