2
$\begingroup$

so I'm having a weird problem. Basically I modeled a Shoe (the one on our Right). Then I of course saved time by deciding to select that shoe, Shift+D (Duplicate), and Ctrl+M (Mirror) it on X axis.

This looks like it totally worked fine and normal within Blender. However, whenever I imported it into Unity, the mirrored shoe shows up 'underneath' the character's foot (shown below).

Does anyone know why this might have happened?

Foot over left shoe in Unity

Shoe looks solid in Blender!

Foot under left shoe in Blender

I should clarify that both do Export with solid materials; it's just that one decides to go under the foot while the other goes over. Thanks for any help.

enter image description here

$\endgroup$

1 Answer 1

3
$\begingroup$

The normals were inverted when you mirrored your mesh. Unity has probably backface culling enabled which make the faces transparent when viewed from the wrong side.

In Blender, you can see face orientations by enabling Face orientation in the Overlays :

enter image description here

enter image description here

The front side of the faces are displayed blue and the backside are red. Blender has also backface culling option and if you enable it, the faces will become transparent when viewed from the back side :

enter image description here

enter image description here

Here you can see through the second cube because his faces are turned inside out.

To fix your problem go back to Blender. Select your shoes, go to Edit Mode, select everything whit A and press ALT+ N then Recalculate Outside. Then, re-export your mesh.

It should fix it.

$\endgroup$
2
  • $\begingroup$ That's it! Thanks so much!! $\endgroup$
    – yunum
    Dec 23, 2021 at 12:13
  • 1
    $\begingroup$ I'm Glad I helped. $\endgroup$ Dec 23, 2021 at 12:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.