1
$\begingroup$

Must I upgrade the system's python from 3.7 to 3.9.9 or is it something else?

blender -b -E CYCLES -f 1

Color management: using fallback mode for management
Color management: Error could not find role data role.
Blender 3.0.0 (hash f1cca3055776 built 2021-12-03 00:34:54)
BLT_lang_init: 'locale' data path for translations not found, continuing
Color management: scene view "Filmic" not found, setting default "Standard".
blf_load_font_default: 'fonts' data path not found for 'droidsans.ttf', will not be able to display text
blf_load_font_default: 'fonts' data path not found for 'bmonofont-i18n.ttf', will not be able to display text
blf_load_font_default: 'fonts' data path not found for 'bmonofont-i18n.ttf', will not be able to display text
Python path configuration:
  PYTHONHOME = (not set)
  PYTHONPATH = '/usr/lib/python3.7'
  program name = '/usr/local/bin/blender'
  isolated = 0
  environment = 1
  user site = 0
  import site = 1
  sys._base_executable = '/usr/bin/python'
  sys.base_prefix = '/home/sybren/buildbot-builder/linux_glibc217_x86_64_cmake/build_deps/deps/Release/python'
  sys.base_exec_prefix = '/home/sybren/buildbot-builder/linux_glibc217_x86_64_cmake/build_deps/deps/Release/python'
  sys.platlibdir = 'lib'
  sys.executable = '/usr/bin/python'
  sys.prefix = '/home/sybren/buildbot-builder/linux_glibc217_x86_64_cmake/build_deps/deps/Release/python'
  sys.exec_prefix = '/home/sybren/buildbot-builder/linux_glibc217_x86_64_cmake/build_deps/deps/Release/python'
  sys.path = [
    '/usr/lib/python3.7',
    '/home/sybren/buildbot-builder/linux_glibc217_x86_64_cmake/build_deps/deps/Release/python/lib/python39.zip',
    '/home/sybren/buildbot-builder/linux_glibc217_x86_64_cmake/build_deps/deps/Release/python/lib/python3.9',
    '/home/sybren/buildbot-builder/linux_glibc217_x86_64_cmake/build_deps/deps/Release/python/lib/lib-dynload',
  ]
Internal error initializing Python!
Fatal Python error: init_fs_encoding: failed to get the Python codec of the filesystem encoding
Python runtime state: core initialized
ModuleNotFoundError: No module named 'encodings'

Current thread 0x00007f6f5cb0f200 (most recent call first):
<no Python frame>
$\endgroup$
2
  • 2
    $\begingroup$ You need at least python V3.9 for Blender 2.93+ $\endgroup$
    – Gorgious
    Dec 23, 2021 at 10:52
  • $\begingroup$ Will gladly marks as answer. Yet, the problems ensue upon installing V.3.9 $\endgroup$
    – jjk
    Dec 23, 2021 at 13:49

1 Answer 1

0
$\begingroup$

Unlucky git pull?

I ran into this compiling Blender 3.1.

strace ./bin/blender

showed me that it was looking for python3.10 but there was no python3.10 found here:

cd build_linux_full    
ls bin/3.1/python/bin/

but there is here:

ls ../lib/linux_centos7_x86_64/python/bin

I must've done my update at the wrong time? I went back up to cd ../blender and did a make update and built again and the problem was solved... now I've got Blender 3.2 with python 3.10 found here:

ls bin/3.2/python/bin/
$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .