I'm having a problem with Eevee that's to do with shadows disappearing.

A number of people on the internet seem to be having similar problems, but i've failed to find the solution.

Basically, as you can see in the gif, as the camera zooms in, the shadows at the edge of the frame start to disappear.

The scene is being lit by an HDRI and one spot light.

I've tried adjusting just about every parameter that's to do with shadows in the render settings and in the lights settings. I've tried adjusting clipping as well. It seems as though Eevee just stops rendering objects once they disappear from of the frame thus removing the shadows as well.

GIF showing the problem

My settings:

render settings

enter image description here

Would really appreciate any input on this. Fixes, possible workarounds, anything.

Thank you.

SOLUTION: Enable Overscan under Film in the render settings.



Browse other questions tagged .