1
$\begingroup$

I'm wondering what I'm missing to make this texture applied onto the back walls as if z-axis scale has gone off the scale, rather than rendering as tiles displayed by the material preview.

Thanks muchenter image description here

$\endgroup$
2
  • $\begingroup$ You may want window mapping (from your texture coordinate node), or you may want a project-from-view UV map. In either case, you'll want an orthogonal view (numpad 5.) $\endgroup$
    – Nathan
    Commented Dec 22, 2021 at 5:46
  • $\begingroup$ It's a problem of UV mapping. Your wall is probably not UV unwrapped yet but you use UV coordinates output from your textures coordinate node. $\endgroup$ Commented Dec 22, 2021 at 6:10

1 Answer 1

1
$\begingroup$

Your wall is not UV unwrapped yet. To use the UV output from the Texture Coordinates node, you need to UV unwrap your mesh first, otherwise you will always end up with undesired results like this.

You can fix this by either :

-By selecting your wall in Edit mode and press U, then Unwrap and playing around with the Scale and Location of your Mapping node or

-By using the Generated output of the Texture coordinates node and playing around with the Scale and Location of your Mapping node.

$\endgroup$
2
  • $\begingroup$ Thanks so much for taking the time to explain and provide options for the fix @mqbaka!!! Very helpful and worked like a charm! $\endgroup$
    – Strots
    Commented Dec 23, 2021 at 3:32
  • $\begingroup$ Glad I helped. You may accept the answer so that the topic will be considered as solved? $\endgroup$ Commented Dec 23, 2021 at 5:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .