For too diddly-darn long I've been trying to create a specific scene in blender involving a large splash as a car enters the water. It's never resulted in a particularly satisfying splash and today I began anew with a fresh file and stripped back the scene to the root of the problem.


The weird splash

I have a still source of water and an effector (invisible but very similar shape to the car) dipping into it as shown. However it seems only to push the water rather than making a large splash. It just doesn't look right. I haven't made any adjustments to the fluid simulation except for decreasing it's viscosity. Can someone explain why the water behaves so weirdly and what I can do to produce a more realistic splash?

Regards, Confused User

  • 2
    $\begingroup$ It would be easier if you could upload the blend file. $\endgroup$ Dec 21, 2021 at 6:55
  • 1
    $\begingroup$ Looks like you have viscosity turned on … $\endgroup$
    – Chris
    Dec 21, 2021 at 8:19
  • $\begingroup$ there are also some values like Resolution, Particle Radius and Sampling that may play with the water thickness... As Mqbaka says, please share your file: pasteall.org/blend $\endgroup$
    – moonboots
    Dec 21, 2021 at 9:01
  • $\begingroup$ My Blender file is 29mb so pasteall and blend exchange don't allow me to upload the file. I don't know how to reply to specific comments so I hope you see this. Again, no settings on the water have been changed except viscosity 0 and I use a simple effector keyframed to dip into the water as shown. I am inclined to believe that a higher resolution division would help as mine is currently set to 32, but my computer is just a crappy lil laptop and I don't think it can run it. $\endgroup$ Dec 21, 2021 at 22:49
  • $\begingroup$ I have since removed the fancy car model and uploaded the file $\endgroup$ Dec 21, 2021 at 23:28

1 Answer 1


There are a few options to create big splashes.

1. in the Physic Properties settings of the Liquid Domain is an option called Fluid > [X] Liquid > [X] Fractional Obstacles. When it's enabled obstacles will create much more splashes.

2. you are dipping the car into the water ;-) There won't be big splashes. You need to throw the car into the water. Change the keyframes so the car will drop from about 20m height within the first 20 frames. It needs some speed.
Rigid Body physics also works.

3. the higher the Fluid > Settings > Resolution Division value is the more liquid the fluid will be. But this also increases simulation baking time and the number of vertices. This value depends on the size of the liquid domain.

In the example, the dummy car is scaled down to 0.5 to make the splashes look bigger (just a test). If you have a car in real-world size, it might be better to leave the car alone and double the size of the liquid domain and the liquid source and adjust the Resolution Division value. Don't forget to apply the Scale to the objects with Ctrl+A in Object mode.

Increasing the FLIP Ratio might be another option (not tested). The default value is 0.970, and the max is 1.0. Not sure if it has a big impact.

Examples for different Resolution Division values

  • 96 Resolution Division, several minutes baking, 170k vertices, lag in viewport (2 frames/sec playback speed in solid mode) hi res example

  • 48 Resolution Division, a few minutes baking, 41k vertices medium res example

  • 32 Resolution Division, quick baking, 17k vertices, low splash and it goes in opposite direction low res example

  • animation with 40 Resolution Division
    example animation 40 res


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .