2
$\begingroup$

It's been a while since I last did cloth simulation, and I can't remember how to get it right for the life of me. When I start the animation, the clothing clips through the body and crumples itself up.

A demonstration of the current cloth physics.

I've looked at my older posts about cloth simulation and observed my settings from older project files, but the problem persists. What exactly am I doing wrong here?

You can find the .blend file here! Thanks in advance!

$\endgroup$
3
  • $\begingroup$ did you apply scale? What about collision and self collisions settings? This usually happens when the collision margin is bigger than the length between 2 vertices or without applied scale $\endgroup$
    – MikoCG
    Commented Dec 20, 2021 at 7:22
  • $\begingroup$ @MikoCG Yes! Also, the object collision settings have a distance of 0.001 m. I just lowered the self collision distance to 0.001 m, here are the results. $\endgroup$
    – MEATTAIL
    Commented Dec 21, 2021 at 20:27
  • $\begingroup$ that looks like way too strong sewing power, it flew into each other way too fast and edges and vertices interpolated with each other and made this clumsy mess $\endgroup$
    – MikoCG
    Commented Dec 22, 2021 at 6:56

1 Answer 1

3
$\begingroup$

The cloth simulation fails because a big lady needs a big shirt. The shirt fabric (mesh) that you use is too small and it has not enough geometry. Try something like the following and add a Subdivision Surface modifier with one or two levels.

To be able to close the sewing gaps, it's a good idea to mark the edges that should be sewn with different marking such as Seam, Freestyle, Bevel, Sharp.

sewing the shirt

Also, your body model has a lot of vertices (280k). This slows down the cloth simulation. It would be better to do a retopology of the model first. Or for a quick test, you also can duplicate and remesh it. Then work with the dummy model. Don't forget to disable the Collision modifier on the original model and add one to the dummy model.

running the cloth simulation

There seems to be a bug in Blender, and there will be sewing gaps. You need to close them manually.

First, you should remove the loose threads. Find one and select it. Now you can select all of them with Select Similar > Amount of Connecting Edges and delete them.

Since you marked the edges you can select them after the simulation run and the cloth modifier has been applied with Select Similar. Use Edge > Bridge Edge Loop to connect them.

Unfortunately, this only works for one seam at the same time. But you can save the selection in a vertex group. Then you switch the Selection mode to Substract and remove all vertices from the selection except the two that you want to connect. With X-ray mode and Lasso selection, this is done quickly.

closing the gaps

The shirt still looks a bit wrinkled. However, it can be smoothed out quite easily with the Smooth brush in the Sculpt mode.

For animation, it could be better to create the shirt in T-pose because automatic weights don't work well in the area under the arms.

final shirt

$\endgroup$
1
  • $\begingroup$ Thank you so much for the super detailed response! I really appreciate it. I like to work on clothing during the sculpting phase, and I've found that duplicating the body, remeshing it, applying a shrinkwrap modifier, and scaling it all up by 5 helps a ton with cloth sim. Here are my results so far! By the way, am I supposed to be working at a 5x scale? I saw a tutorial mention it, and physics sims seem to seem much more smoothly that way. Also, I imported another character model which also happened to be at 5x scale. Thanks again! $\endgroup$
    – MEATTAIL
    Commented Dec 29, 2021 at 4:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .