2
$\begingroup$

Was following a tutorial on objects, animations, geometry nodes etc. And within the Geometry Nodes section I have a value node in which I've used the function #frame on a mesh. Following the tutorial when he presses spacebar/start the mesh begins to move in-sync with the model that has actual keyframes. However when I do it nothing happens. Then I noticed if I click and drag the numerical field in the value node the number resets to whatever frame it was at and I get the error "Can't edit driven number value, see graph edtor for the driver setup". I can manually enter the frame number and hit enter but it still doesn't do anything when I hit play/spacebar.

The intent is for the geometry nodes to cause a randomized moving effect of the mesh without having to animate it. However I can't get past this point so the end result won't even matter.

Any ideas would be greatly appreciated. I looked around SE for others with similar issues but their resolution didn't work for me.

value node

There's nothing in the graph editor or driver: graph editor

$\endgroup$
4
  • 1
    $\begingroup$ hoover over the value box in the value node and right click. select delete driver. then type #frame in the box. Should fix it. If not, can you add your blend file to your question? (How to add a blend file) $\endgroup$ Dec 18, 2021 at 21:12
  • $\begingroup$ @MartyFouts it works! can you please post as answer? I can't believe it was that simple lol it's finally moving. I still can't scrub through and if I manually enter a numerical value it breaks it but if I delete driver again and then type in #frame and just leave as is, it works! good enough for me lol I just positioned the mesh where I want it to start and all is well. $\endgroup$
    – SorryEh
    Dec 18, 2021 at 21:20
  • 1
    $\begingroup$ Sure. Answer posted. I don't know what was wrong, without looking at the broken blend file, but that was the easiest fix. Maybe could have looked at it with the driver editor to see what happened, but why bother? $\endgroup$ Dec 18, 2021 at 21:23
  • 1
    $\begingroup$ yeah I followed it to the letter and even redid the steps, perhaps just a bug I'm encountering. It's BlenderGuru's Donut tutorial part 12. It's pretty straight forward and haven't encountered issues until this one. But you fixed it, so thank you! haha now I can spend time on figuring out how to do other things not in his tutorial to make it my own. thanks again Marty! $\endgroup$
    – SorryEh
    Dec 18, 2021 at 21:25

1 Answer 1

1
$\begingroup$

The driver appears to be screwed up. There are several possible ways to fix it. This is one of the easiest:

  • Hoover over the value box in the value node.
  • Right click.
  • Select delete driver from the dropdown menus.
  • type #frame into the value box.
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.