3
$\begingroup$

My Model in Frame 1 is at the end of vertical plane. On Frame 240 he comes near the camera.

I did basic walk animation in Frame 1 and went to Action Editor->Clicked F->Clicked X to close it.Then opened NLA Editor, clicked my saved action(metarigAction.001)-> NLA track opened.Pressed N-> Increased Repeat to 3.0 from 1.0

After that came back to frame 1 and clicked the bone(which control whole model) Inserted keyframe(location) then transferred the bone to frame 240 again location keyframe

My model was successfully able to walk from frame 1 to 240

However if I try to animate after 240 its not animating. Example After reaching frame 240 I am going to frame 280 and lifting my model hand to salute.If I insert Keyframe and if I check the animation

What happen mean the last saved position(salute) is coming exactly from frame 1 to frame 240.No walk animation. It look like some1 pushing it in the last saved position from beginning to end.

Normal Timeline

enter image description here

NLA Editor Image at frame 1,240

enter image description here

enter image description here

How to get back to normal animation after frame 240 i.e. I want to use the normal animation timeline. Please assist.

Below Image is saved metarigaction at frame 1(just a walk from frame 1 to 80,u can c only 3 keyframes in timeline) enter image description here

Below Image is after NLA Editor starting frame at 1 and ending at 240. enter image description here

I want this action NLA(Walk cycle) to be there till frame 240 and then need normal animation timeline.

After NLA When I tried to change back to metarigaction,normal timeline(4th image from top) is coming but animation missing as stated earlier.

How to get back to normal animation timeline retaining NLA action and proceed further as normal?

At frame 240 enter image description here

At frame 241 enter image description here

$\endgroup$
1
$\begingroup$

adding a keyframe, you've started creating an action. enter image description here To get back to "normality" :
open dopesheet
enter image description here

In dopesheet, go to action editor
enter image description here

here you can edit or remove your action enter image description here

If you're editing an action (hello) animating the same bone(s) as the other one (walk cycle), the action above is the only one that will do something. The action below is "muted" (at least the part that uses the same bone).
enter image description here

$\endgroup$
  • 1
    $\begingroup$ I have done this to save my action.pls recheck my post I have added few more details.I hope it will better explain my issue $\endgroup$ – Lambo Feb 13 '15 at 21:28
  • $\begingroup$ @Lambo You can't use an action (walk cycle reapeted) and "normal" animation. "Normal" animation is all keyframes in 1 single action. You can't do that without baking your walkcycle and come back to a single action for all. $\endgroup$ – Bithur Feb 13 '15 at 22:12
  • $\begingroup$ Bithur: I still don't get it.can you please help in this.garagegames.com/community/forums/viewthread/91081 In above link can u check 6th comment from last it will be "Yep. Pin the action timeline. you'll see an icon for it right next to the action selection dropdown" what is the meaning of that line.I am using blender v2.73 $\endgroup$ – Lambo Feb 13 '15 at 22:15
  • $\begingroup$ @Lambo Not sure but i think it's about linked duplicated actions (same as Alt+D for objects) clicking the number makes it single user. not really sure... As thet say : "Blender's action editor/NLA edior function seems to be the least intuitive thing I have ever encountered. It's probably just me." $\endgroup$ – Bithur Feb 13 '15 at 22:30
  • $\begingroup$ Bithur: I figured out how to do it. I have to create an new action. After that Entering into metarigaction Have to click->add strip->new action name then it will be inserted as a track and I draggeed it and fixed at frame 241 but when I run the animation at when frame 241 where new action added my model leg disapppears I mean leg going below the ground.I checked in my newly created action.Leg is fine and above the plane.wat might went wrong? $\endgroup$ – Lambo Feb 15 '15 at 4:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.