4
$\begingroup$

I am using blender to animate a skeletal mesh and then export it in FBX format.

I exported with Z axis as up and positive X as forward

There are certain problems with it.

Importing only the mesh complains for some missing bind poses. I use t0 for bind pose.

The mesh orientation is correct but when importing with animations the warning says imported bone transform is different from original

Then when i play the animation the whole skeleton is lying down while it is standing up in blender.

what am i doing wrong?

Also I would like to choose which animations to export exclusively! how do i do that?

EDIT: When I import the animations there are some other weird animations that get imported each of them just 2 frame long, what are those?

Also please guide me to a learning resource on NLA and actions editor.

$\endgroup$
3
$\begingroup$

You have three ways to control how animations are exported in FBX:

  • NLA Strips and All Actions disabled: only 'active' actions in scenes will be exported (i.e., actions assigned to objects/armatures/etc.).

  • All Actions enabled: all existing actions are exported for all compatible objects (because there is no way by default in Blender to restrain a set of actions to a specific object).

  • NLA Strips enabled: each strip of the NLA of each object is exported as a single action. This is the best way to get precise control over which action is exported for a given object.

As for orientation and armature issues, this is a well known issue of current code (at least with UE4, for some reason Unity seems to work much better), which is being investigated - it is still completely unclear whether issue is in UE4 reading code, or Blender writing code, or both…

$\endgroup$
  • $\begingroup$ So you mean there is no fix for that other than rotating stuff in the ue4 (which is possible) ? $\endgroup$ – user1062760 Feb 14 '15 at 7:15
  • $\begingroup$ Currently, yes. Just be sure to never use 'Apply Transform' when exporting with armatures, since this is known can of worm. But it does not prevent all issues with UE4. $\endgroup$ – mont29 Feb 14 '15 at 9:10
2
$\begingroup$

I am completely new to Blender, so I haven't even tested this yet, but here's a solution for the skeleton lying down problem.

"Could anyone find a solution to the rotation problem, other than rotating the character by 90° around X in Blender? Whatever I select in the exporter, my character appears face-down in UE4." asked by Daerst

"Just don't scale in the exporter. Use scale = 1.0 in the exporter and scale the model in Unreal Scene, use Blender default unity as cm or blender world scale to Metric and change to 0.01 but don't scale in the exporter." answered by vBalbio

Answer from vBalbio on the Unreal Engine forum. https://forums.unrealengine.com/archive/index.php/t-128.html

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.