1
$\begingroup$

I'm making a Prism. It's not based totally on reality, so it can count as a basic representation of it.

As you can see on the image, there are reflections made by the objects, but how can I erase exactly those reflections? I already unchecked the box on the objects that are from 'Transmission' and 'Shadow'...but still I see them on there.

Is there any solution to this?

Screenshot of the problem

If i add more Roughness to the Glass BSDF, the reflections dissapear, but the transparency isnt the same.

$\endgroup$
6
  • $\begingroup$ reflections are glossy rays $\endgroup$
    – Bithur
    Feb 13, 2015 at 15:34
  • $\begingroup$ How can i hide them? or is it impossible? $\endgroup$
    – beavoru
    Feb 13, 2015 at 15:37
  • $\begingroup$ uncheck glossy from ray visibility, so this object wont apaer in reflection $\endgroup$
    – Chebhou
    Feb 13, 2015 at 15:41
  • $\begingroup$ That doesnt work, already tried :( If i add more Roughness to the Glass BSDF, the reflections dissapear, but the transparency isnt the same. $\endgroup$
    – beavoru
    Feb 13, 2015 at 15:43
  • $\begingroup$ Hmm, wait, there was an additional object hidden, i deleted it and it worked, how silly of me.. But yet, the answer you gave me helped, so if you want please post it as an answer because it worked :) Thanks! $\endgroup$
    – beavoru
    Feb 13, 2015 at 15:47

1 Answer 1

2
$\begingroup$

To prevent an object from appearing as a reflection on other objects, uncheck Glossy under Ray Visibility in the Object tab:

enter image description here

$\endgroup$
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .