1
$\begingroup$

I'm building a model that's very small, about a square millimeter, that I intend to have 3d printed. I've figured out the model at normal blender dimensions, with the units set to "None", and then I just set my units to "Metric" and scaled the thing down considerably.

Although I could use this model, I might want to make further changes, but since it's so small, it's difficult to work with since the viewport panning is messed up so closely zoomed.

How do I change the scale of my viewport from "meters" to something smaller, like "milimeters"? I've googled around and only find unrelated information.

Here's a screenshot to illustrate my problem.

enter image description here

Notice how in the top left corner of the viewport it says "User Persp" with "Meters" under it. I suspect that's what has to change.

$\endgroup$
  • $\begingroup$ The viewport controls don't behave any differently at different scales AFAIK, I suspect you are encountering this. Try selecting your object and pressing numpad ., then see if the view navigation feels more natural. $\endgroup$ – gandalf3 Feb 11 '15 at 23:05
  • $\begingroup$ @NoviceInDisguise not infinitely. you can zoom about to 1/1000 (milimeter size), 1um (micro) is the smallest thing i could see or model/scale. $\endgroup$ – Bithur Feb 11 '15 at 23:37
  • $\begingroup$ Note that in Orthographic views you will be able to snap to a much smaller grid (depending on your zoom). $\endgroup$ – VRM Feb 11 '15 at 23:38
  • 1
    $\begingroup$ @blaineh don't worry too much about that, scale your object to be able to do what you need. 3D printing sofwares can handle scaling before printing. Or edit your object and scale it when you're done in blender. $\endgroup$ – Bithur Feb 11 '15 at 23:44
  • 1
    $\begingroup$ @blaineh "meters" or "feet" in the top left corner of the viewport is about the unit your using, not the scale. It should say metric or imperial. $\endgroup$ – Bithur Feb 11 '15 at 23:54
9
$\begingroup$

You can change the scale of the whole scene to metric .001 (one thousandth of a meter=1mm).

enter image description here

But to be able to work at such small scale you also have to adjust the scale on the viewport as well:

enter image description here

Here's what a 1mm x 1mm x 1mm object looks like in with such scaling: enter image description here

$\endgroup$
3
$\begingroup$

Just work in standard Blender units and pretend they are millimeters. When uploading your model to the 3D printing service you should be able to select that one Blender unit equals one millimeter!

$\endgroup$
  • $\begingroup$ Although this is a good answer, the other one is more technically correct and will help people in the future. This is what I've pretty much ended up doing though :) $\endgroup$ – blaineh Feb 12 '15 at 17:09
  • $\begingroup$ Completly correct....but the answer was not there, when I added the comment ;) Where can I find the same settings in Blender 2.8? $\endgroup$ – user60781 Sep 4 at 18:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.