5
$\begingroup$

When unwrapping a seamed object, my UV coordinates come out very weird. Whereas several sections have equal area on the model, they come out distorted when projected to the UV mappings:

model with the uv mapping side-by-side

closer view of the UV map:

closer view of the uv map

I already tried applying the object's scale (Ctrl+A, Scale). It did help, but the UV is still distorted a bit. Is that normal, or am I doing something terribly wrong?

.blend file here (the model in question is in the 4th layer)

$\endgroup$
15
  • $\begingroup$ What method of unwrapping did you use? Although it is common to edit UV's manually, it shouldn't come out this bad. Try Project From View when in side view. $\endgroup$ – VRM Feb 11 '15 at 23:29
  • $\begingroup$ I used just the Unwrap, as I wanted to use the seams I had created. I can Project From View that ring, but can't do that with the cylinder as it will never capture all of it. Also, with Cylinder Projection, the texture will be distorted to fit the UV projection, so I can't just put something like a decal and expect it to follow the model, can I? $\endgroup$ – Délisson Junio Feb 11 '15 at 23:38
  • $\begingroup$ Something like Shrinkwrap? $\endgroup$ – VRM Feb 11 '15 at 23:39
  • $\begingroup$ Um yea, that sounds right. $\endgroup$ – Délisson Junio Feb 11 '15 at 23:48
  • $\begingroup$ There is a modifier called the Shrinkwrap modifier, you add it to the decal and then select the target mesh. You can edit the offset and a few other things. Add a sub-div modifier right before it on simple just to give more vertices for it to work with. $\endgroup$ – VRM Feb 11 '15 at 23:57
3
$\begingroup$

This is probably caused by the modifiers added to the mesh.

In Orthographic mode Numpad-5, Back view Ctrl-Numpad-1. You can unwrap it with U Unwrap from View without the distortion:

enter image description here

$\endgroup$
2
$\begingroup$

I had the same problem, finally i found out that it was the UV Unwrap Method (Previously called "Edit Mode > Find the UV calculation options")

In current version after you Unwrap your model you can find it on Tools Panel and its called Method. After changing it from Angle Based to Conformal I have straight edges in my UV map (previously edges were distorded).

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.