2
$\begingroup$

I've disconnected 2 bones, with Alt P > Disconnect. They are definitely disconnected - they move independently in Edit Mode and under the Properties > Bone tab > Relations no parent is shown for them. But then when I move their former parents in Pose Mode, they follow along as though there was a Keep Offset parenting on them. That shouldn't happen, right? I've tried it several times. There's no constraint on the disconnected bone, no drivers.

enter image description here

$\endgroup$
  • $\begingroup$ apparently there is no tag for anything like 'parent' or 'child'. I don't know what gets used instead. $\endgroup$ – kim holder Feb 11 '15 at 20:48
  • $\begingroup$ I tried creating a new bone and doing the same thing. No dice. In fact, i can see that right after unparenting it, when i select it and try to move it, the former parent immediately reappears in the Bone > Relations Parent field. $\endgroup$ – kim holder Feb 11 '15 at 20:53
  • $\begingroup$ Does anybody show up in the objects parent options? $\endgroup$ – Scalia Feb 11 '15 at 20:54
  • $\begingroup$ I added a snapshot. Nope. $\endgroup$ – kim holder Feb 11 '15 at 21:00
  • $\begingroup$ Was it extruded from that bone? You might need to press P > Separate by Selection $\endgroup$ – VRM Feb 11 '15 at 21:04
3
$\begingroup$

you have to really delete the parenting. In edit mode select your bone, in bone's options tab it's parent should appear, click X.

enter image description here

But the real problem was...

In pose mode, adding a constraint that needs a target (IK, track,...) with hotkey Ctrl+Shift+C should be done selecting it (the target) first, then the bone to constraint. If you don't select a target, an empty is added and becomes the target. This won't happen using the constraint menu.

$\endgroup$
  • $\begingroup$ five bucks and +1 for doing this as I commented... $\endgroup$ – Scalia Feb 11 '15 at 20:55
  • $\begingroup$ did that... see added graphic $\endgroup$ – kim holder Feb 11 '15 at 20:59
  • $\begingroup$ no parent, no constraint, no driver, no keyframe??? $\endgroup$ – Bithur Feb 11 '15 at 21:11
  • $\begingroup$ In fairness, the parenting thing all happened before i tried to add the constraint. I was trying to push on once it behaved the way i expected. $\endgroup$ – kim holder Feb 11 '15 at 21:38
  • $\begingroup$ i'd really like to see the not saved blend. And a detailed undo list to see what happened. $\endgroup$ – Bithur Feb 11 '15 at 21:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.