0
$\begingroup$

I can't for the life of me figure out how to make a video game asset material look right in Blender. Here's a link to .blend with the asset and packed textures. The textures seem out of scale... And that hexagon pattern is only visible at a certain angle in the game, so it must be either specularity or roughness alpha but it just doesn't look right...🤷‍♀️ Examples of what it should look likeenter image description here enter image description hereenter image description here

$\endgroup$
4
  • $\begingroup$ Please change the title to something more relevant and describing what you are trying to achieve. Also, please embed screenshots directly in your post to illustrate the problem. Finally, use blend-exchange.com to attach your blend file instead of a third party site. All this should help you and the community to get some answer. Thx. $\endgroup$
    – Bruno
    Dec 15, 2021 at 23:35
  • $\begingroup$ Idk how else to describe that I have an exported mesh and idk how to plug the textures right so they look like the asset in the game 🤷‍♀️ $\endgroup$ Dec 16, 2021 at 13:08
  • $\begingroup$ Have you tried to mix the hexagon pattern into the roughness or specular value? $\endgroup$
    – Blunder
    Dec 18, 2021 at 4:05
  • $\begingroup$ Yes, I did, but it appears on black lines too >.< And I don't understand what the black and white texture is there for $\endgroup$ Dec 18, 2021 at 11:54

1 Answer 1

0
$\begingroup$

Here is a try to match reference images. The colors heavily depend on the lighting. The used HDRI is called Abandoned Tank Farm 03 screenshot 2 screenshot 1

To get this glossiness in the light that reveals the pattern you need to mix a grey value texture that looks like the following image. We use it for the Roughness or Specular slot of the Principled BSDF. It turned out that the Specular slot does here the better job with a Roughness value of 0.2 to 1.4.

specular texture

You can use the Master_FloorSystem1_Dif_01.tga image to control where you want to have to pattern. It has an alpha mask.

The problem is the Color Space. If you set it to sRGB then the alpha value affects the color and the transparent spots become black. I think this is the so-called "Premultiplied Alpha" that kicks in. But I'm not an expert on that. Anyways, it's bad and we don't what it because you need the "color" (grey-values) for variation of the glossiness of the black block.

Now you think, let's set the Color Space to Non-Color to get the raw values. Yes, indeed then the color values are no longer affected by the alpha value. But now the "color" values (in reality they are gray values) have too little contrast to be of any use. Dang!

Long story short, I've ended up using this image in two Image Texture nodes. Set the Color Space of the first to sRGB and the other one to Non-Color. Then you can use them for the mix factor and for the color that creates this noise that you see on the thick black line.

shader nodes

In the Render Properties > Color Management settings, you can set the Look to High Contrast. Or try Standard for View Transformation. (This will give you non-realistic colors. But hey, it's a computer game. It affects the glossiness. You need to adjust the colors a little.)

$\endgroup$
4
  • $\begingroup$ Omg u are a genius 😲 It'll take me some time to understand what's going on and why... So far 2 questions though - how do u set up the same texture to NC and rgb? When I change one, the other changes too (I have to use a copy) and how come alpha map is being read off the "color" ...connector (I forgot what they're called) and not "alpha" one? Unless I misunderstood smth, I'll look at it tomorrow more thooughly $\endgroup$ Dec 18, 2021 at 19:32
  • $\begingroup$ You're welcome :) When you duplicate the Image Texture node the nodes are linked and share the same settings, the so-called data-block. To make them use their own instance you need to click the number ("2") right next to its name (=> blender.stackexchange.com/a/115984/107598 - this question is also about the RGBA problem.) The number is the number of so-called "users" or reference-count => docs.blender.org/manual/en/latest/files/… $\endgroup$
    – Blunder
    Dec 19, 2021 at 14:20
  • $\begingroup$ 2) oh, I see. You have 4 things to mix: the noisy color, the black ground, the alpha mask for the lines, and the mask for the pattern. So 2 colors, and 2 masks. To mix them you would need 2 MixRGB nodes and you would use the Alpha slot to get the mask data. But since the noisy color (Master_FloorSystem1_Dif_01.tga image, sRGB color space) has the premultiplied alpha is it already mixed as we need it. The mix contains RGB+A. So in the end, we only need 1 MixRGB node and can use the color as the factor (Fac). $\endgroup$
    – Blunder
    Dec 19, 2021 at 14:28
  • $\begingroup$ For the sake of completeness. In the N-panel of the shader editor, you can change the alpha behavior. If you set it to Channel-Packed then the alpha no longer affects the colors. But this makes the nodes even more complicated :-/ blender.stackexchange.com/questions/247527/… $\endgroup$
    – Blunder
    Dec 19, 2021 at 15:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .