5
$\begingroup$

I've been trying to precisely position the 3D cursor, something I've always done by positioning it in one of the 3 standard ortho views, and then switching to another and positioning it again. Today it won't work. I press 1 on the number pad and position it nicely, press 7 and do it again, and when I press 1 again it is well above where I want it. Positioning it in 3 puts it off to the right. Every time it adjusts in exactly the same way, hopping around, but never maintains the position I gave it in the previous view.

I've tried checking any settings that could maybe affect it. I'm learning Blender and probably I've missed something, but I've never seen this behaviour before. I have v2.73. What should I do?

Edit: I saw in the answer to 'Precisely move the 3d cursor' that in the N panel in Edit Mode there is a section called 3d cursor, where numerical values are entered. So I placed the cursor in front view, switched to top view, and entered a numerical value for Y (because it only had to be 0 for Y). But that is a workaround and doesn't explain what is going on.

$\endgroup$
7
$\begingroup$

New versions of blender have added a default option on the cursor, snapping it to object's surface. In user preferences (Ctrl+Alt+U or File menu) interface tab, uncheck "cursor depth" to have your cursor free again!

enter image description here

$\endgroup$
  • $\begingroup$ That's a relief - because with that box checked, i couldn't even click and drag in the 3d cursor Y axis position field to adjust it. The numbers kept hopping up in weird increments and didn't want to land on any number in between. $\endgroup$ – kim holder Feb 11 '15 at 17:40
  • $\begingroup$ Glad to help :) Don't forget to save your user's preferences! $\endgroup$ – Bithur Feb 11 '15 at 17:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.