0
$\begingroup$

I'm using a particle system with Boid physics and metaballs to simulate magma rising in the Earth's interior. I want my metaballs to collide and accumulate below the upper plane, so I solidified and added collision physics to it, but that gives my boid metaballs the strange behavior seen in the screen shot. Those under the collision plane rise to a certain level and then instantaneously jump up to the collision plane and then continue to rise from it. Boid metaballs that are not under the collision plane are unaffected. #Smail witnessed something similar. Why is this happening?

FYI: My boid brain prioritizes Flock then Separate, Avoid and Goal, with the light as the goal and the empty sphere just above the emitter plane as the object to be avoided, but these seem to have no affect on the weird "jumping" in location described above. I've tweaked with the settings for days to no avail--hence the title of this post. enter image description here

$\endgroup$

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.