4
$\begingroup$

Context

enter image description here

I have a super simple flat piece of geometry here which I have cut out of with boolean modifiers.

The issue I am encountering is that along many of the cutout edges, there are lots of floating faces.

Image 1 and Image 2 depict show this issue. I have used the rainbow matcap just so it's easier to see the issue.

Image 3 is what the correct bevel should look like.

Image 1

enter image description here

Image 2

enter image description here

Image 3

enter image description here

Troubleshooting

I have done some troubleshooting. My modifier stack with this issue was comprised of a Boolean operation with a bevel modifier attached to it. I applied the boolean operation and took a look at the topology of the object. Image 4 depicts the geometry of the issue. If I auto merge the outermost two edges, the issue gets solved, making the corner look like Image 3. However, this can't possibly be an acceptable thing.

Image 4

enter image description here

How do I solve it so that the bevel works without creating these extra faces?

Additional Information

I have made the blend file available here: https://files.catbox.moe/jvcwlx.blend

In the file are two attempts by me to resolve the issue.

obj #1 is the one that you can see in the screenshots in this post

obj #2 is a fresh attempt to recreate the issue. Note that in this obj, I havent applied the scale. To get a decent bevel, you will need to apply the scale. I have purposely left it unapplied because that might possibly be a factor causing the issue.

I have tested the issue in both 2.9x and 3.0 and it exists in both.

Let me know if you need anything else.

$\endgroup$
3
  • $\begingroup$ are you sure that there are no disconnected vertices, double faces or something like that? Because this looks like you have one object that works as it should and there are duplicated faces that are making that mess... Also can you share this blend file? $\endgroup$
    – MikoCG
    Commented Dec 12, 2021 at 8:32
  • $\begingroup$ I have supplied the blend file. I don't think there are any disconnected vertices because everything is modelled from the most basic cubes and cylinders so I dont think there are any double ups or similar issues. Let me know what you can find $\endgroup$
    – Gunty
    Commented Dec 12, 2021 at 9:10
  • $\begingroup$ well, it is because of those 2 vertices near corners are too close to each other, merge them manually or use weld modifier $\endgroup$
    – MikoCG
    Commented Dec 12, 2021 at 9:50

1 Answer 1

2
$\begingroup$

The overhangs are caused by edges being too close together around a beveled edge. You can merge these edges manually, or you can use the weld modifier to merge verts that are within a threshold.

On the un-applied boolean modifier object, you need to apply scale so that the beveled edge offsets are not stretched by the object transforms.

The file can be foud here

$\endgroup$
5
  • $\begingroup$ Just to make it clear, these issues can all be handled without applying any modifiers. $\endgroup$
    – Ethan-Hall
    Commented Dec 12, 2021 at 9:52
  • $\begingroup$ files.catbox.moe/bs16zz.blend This solution is effective. I have attached the link to the blend file. There are 3 examples which showcase the modifier stack. One can see which is which by looking at the obj names $\endgroup$
    – Gunty
    Commented Dec 12, 2021 at 10:07
  • $\begingroup$ @Gunt.r: i love your solution, but the line isn't straight anymore with your solution proposal....[1]: i.sstatic.net/CXvmc.png ...this is caused by the weld modifier, if it is off: [1]: i.sstatic.net/9Ep4S.png $\endgroup$
    – Chris
    Commented Dec 12, 2021 at 10:26
  • 1
    $\begingroup$ Interesting pickup. Frankly I have no clue what to do about that. I'm very new to blender right now so I'm not exactly in a position to solve this newfound issue... maybe someone else might be able to work out how to make the line straight. $\endgroup$
    – Gunty
    Commented Dec 12, 2021 at 10:57
  • $\begingroup$ You can use Shrinkwrap, modifiers for each axial direction, to project the perturbed verts back onto a boundary object. The boundary object could be custom, or a linked duplicate of the base mesh. Note: Shrinkwrap sometimes will ignore verts that start on the surface of the target object you may need to scale the boundary a bit to fix this. -Important Shrinkwrap Parameters- Wrap Method: Project | Limit: Same value as used in the weld modifier's distance. (Use drivers to sync) | Enable positive and negative projection direction. | Set the target. files.catbox.moe/glh0nb.blend $\endgroup$
    – Ethan-Hall
    Commented Dec 13, 2021 at 1:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .