I'm new to Blender and I'm trying to learn Geometry Nodes but I'm facing an issue: When I try to Shade Smooth with Geometry Nodes seems to only work on Viewport.

I've generated Cylinders and Spheres meshes via Geometry Nodes using the "Set Shade Smooth" node.

It seems to work in the viewport, but when I'll try to render it, it's rendered as "Shade Flat".

Following there's the Viewport example with the Nodes: enter image description here

Here instead the Rendering results: enter image description here

Could you please help me identify the issue? Is It a known bug?

Thank You in advance.

  • $\begingroup$ This Mesh Transformation node group seems to have also a Shade Smooth option. Have you checked if this input is properly connected and works? $\endgroup$
    – Blunder
    Dec 12, 2021 at 6:08
  • $\begingroup$ can u provide blend file? $\endgroup$
    – Chris
    Dec 12, 2021 at 11:55
  • $\begingroup$ The "Mesh Transformation" node has the "Shade Smooth" trigger because the "Set Shade Smooth" was here before. I moved it out to "debug". I've also uploaded the Blend file, it's a bit messy due to debugging and testing, but I hope that's clear enough. $\endgroup$
    – Odiniox
    Dec 13, 2021 at 15:02

1 Answer 1


I found out that just for the Spheres, I've solved the issue by setting the Rotation of the mesh X axis to 0°. It's a Sphere, the rotation shouldn't affect the way it's visualized.

Following the Blend file and the Mesh Transformation Node: enter image description here The "Shade Smooth" input is present but not linked because previously the "Set Shade Smooth" node was here.

Blend File:


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .