0
$\begingroup$

When I move one of the vertices from the torso of my figure, it's like there's a second mesh under the surface. I've tried A > M > Merge By Distance and pretty much all the options in Edit Mode menu Mesh > Clean up but the problem's still there. Is this normal or did I mess up while I was modeling earlier? Also why aren't the edges joined?

Here is how it looks when I pull the vertices to the side: enter image description here

$\endgroup$
1
  • $\begingroup$ maybe you have some edges over some faces, to delete you need to select and press X, if it doesn't work please share your file $\endgroup$
    – moonboots
    Commented Dec 10, 2021 at 4:52

2 Answers 2

0
$\begingroup$

It looks like this could be caused by your mirror modifier.

Click the monitor button in that modifier to hide its visibility. I suspect you'll still see a full mesh rather than just half.

Often when you create the mirror modifier, you may sometimes forget that this is the case. I often have this issue. It's mirroring both halves of your mesh onto the respective other side, but the reflection is not editable by default and obviously gives you dupes.

The solution is to make sure there is a loop of vertices around your model that sit perfectly along the plane of the mirror. Now, in X-Ray mode or wireframe mode, select all vertices on one half of the model (not including the centre loop I just described), and delete them. For best results, identify which side of your model features the edits you made while the mirror was active, then decide which to delete based on this information. Once you've deleted half your model, re-enable your mirror.

Hope that helps.

$\endgroup$
2
  • $\begingroup$ I suspect you might be correct that the mirror modifier is the problem... but how should he delete the "wrong" half? When the mirror modifier is disabled, it doesn't matter if he deletes the left or right half... and if he already edited one side like in the screenshot, this edit will only exist on the side he worked on, so this edit will disappear on the other side when disabling the modifier. And in this case it is of course better to delete the un-edited side... but the edited vertices will only show on one side anyway ;) $\endgroup$ Commented Dec 10, 2021 at 13:21
  • 1
    $\begingroup$ @GordonBrinkmann, fair point about it not mattering which side he deletes in the context of the mirror modifier. I'll edit my answer accordingly. It's best to identify which side you edited and decide which side to delete based on this. $\endgroup$
    – Onyx
    Commented Dec 10, 2021 at 13:45
0
$\begingroup$

If I understand well after the mirror you get some extra edges. In this case use these steps:

Select your mesh, and use Decimate to see what edges are separated when you mirror. You will see separated edges, use undo back to the initial mesh and with Shift + Alt and click select that edges and delete. After that, you will have a clean mesh.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .