File link: .Blend file

I kept a clean topology, all quads while modeling, nonetheless, when the time to close the mesh arrives, I have this.

enter image description here

Is there a way to fill that face with quads without having to do it manually? I tried Face>Grill Fill, and Face>Fill, then triangulate, then triangles to quads, it doesn't work.

I always get something like this.

enter image description here

I guess the only option is to do it manually. But worth asking since doing it manually will be time consuming and it's a situation I face often.

It's part of a droid leg.


  • $\begingroup$ Please share your file: pasteall.org/blend $\endgroup$
    – moonboots
    Dec 7, 2021 at 17:02
  • $\begingroup$ True, sorry. It's done, thanks $\endgroup$ Dec 7, 2021 at 17:10
  • $\begingroup$ Try to use "simple blending" option in the grid fill operator panel (with a span or 2). $\endgroup$
    – lemon
    Dec 7, 2021 at 17:19
  • $\begingroup$ don't you want to simply extrude inwards and close with F? Do you absolutely need quads? $\endgroup$
    – moonboots
    Dec 7, 2021 at 17:21
  • $\begingroup$ Closing with F causes crests with the subdivision surface modifier, that can be minimized with an edge loop. I don't absolutely need quads. I just want to know if there is a better way to solve this. $\endgroup$ Dec 7, 2021 at 17:33


You must log in to answer this question.

Browse other questions tagged .