2
$\begingroup$

Texture paint

I want to Texture Paint something and my texture is white. In material viewport and render preview it appears completely white, without shades. I also can´t paint on it, if i try nothing happens. What can I do? Here´s the file (hope it works):

https://www.dropbox.com/sh/vzwcsr3ridb8ahg/AABo0ZRR8cQG5T-_2JdNQMfya?dl=0

screenshot

I changed the texture to black with 1024px and added the Diffuse Node and toyed along with the viewports. Still can´t paint on the object.

$\endgroup$
2
  • $\begingroup$ plug it into a DIffuse node before the Output. Why can't you paint on it? Maybe share your file $\endgroup$
    – moonboots
    Commented Dec 5, 2021 at 16:59
  • $\begingroup$ The Diffuse Shader just makes the object pink. I uploaded the file and linked it above. $\endgroup$ Commented Dec 5, 2021 at 20:53

1 Answer 1

1
$\begingroup$

You don't have any HDRI picture for your world (or at least you haven't packed it) so the background is pink, remove the Environment Texture node from the World Shader Editor:

enter image description here

Back to Shader Editor > Object mode, plug the Image Texture into a Diffuse node, maybe load a lighter picture (the current one is 6144 px large)?

enter image description here

Create a sun in the scene, give it a Strength of 4 (just to check the result in Rendered preview mode). Select your anvil and switch it to Texture Paint, try to paint, if it still doesn't work, switch from a mode to another (From Material Preview to Solid) and then back to the mode you want (except Render preview). It should work.

For your last question:

  • Choose Blend > Mix instead of Add
  • Close the Texture Mask
  • Keep the Texture if you want but in that case choose another color than black.

enter image description here

$\endgroup$
8
  • $\begingroup$ I opened the file again today. I have shades now, but still can´t paint on the object. I actually use a HDRI picture, but didn´t pack it. Sry. $\endgroup$ Commented Dec 6, 2021 at 14:33
  • $\begingroup$ have you tried to switch from a display mode to another? Maybe share your file again? $\endgroup$
    – moonboots
    Commented Dec 6, 2021 at 14:34
  • $\begingroup$ i have added the current file under the old link. switching between display modes didn´t change anything. $\endgroup$ Commented Dec 6, 2021 at 15:09
  • $\begingroup$ @Irenäus Blaszkiewicz I've edited my answer, I hope it will fix your problem $\endgroup$
    – moonboots
    Commented Dec 6, 2021 at 15:28
  • $\begingroup$ It worked somehow, but I am not sure if it has something to do with the lighting, I just pushed my point lightsource further away. $\endgroup$ Commented Dec 6, 2021 at 17:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .